<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en-GB">

<head profile="http://gmpg.org/xfn/11">

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Driver badly hurt after light pole collision  - Cayman Islands Headline News  : Cayman News Service</title>

<!-- <link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear7.5/style.css" type="text/css" media="screen" /> -->

<!-- <link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear7.5/style-font.css" type="text/css" media="screen" /> -->

	<!-- Responsive Design Resources -->
	<!-- <link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear7.5/style-responsive.css" type="text/css" media="screen" /> -->
<link rel="stylesheet" type="text/css" href="//caymannewsservice.com/wp-content/cache/wpfc-minified/jm81bc6p/6hpnc.css" media="screen"/>
	<meta name="viewport" content="width=device-width,initial-scale=1" />

<link rel="pingback" href="https://caymannewsservice.com/xmlrpc.php" />

<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="D1kGA0KHCR-7CU-o08fDKcYvl5zvzQJld3jKDhwIYrY" />
<meta name="msvalidate.01" content="95CEA9205167F6EB90909BB9DE528490" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Cayman News Service &raquo; Feed" href="https://caymannewsservice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cayman News Service &raquo; Comments Feed" href="https://caymannewsservice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cayman News Service &raquo; Driver badly hurt after light pole collision Comments Feed" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/caymannewsservice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<!-- <link rel='stylesheet' id='feelbox-default-style-css'  href='https://caymannewsservice.com/wp-content/plugins/fl3r-feelbox/css/style.css?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='feelbox-icons-style-css'  href='https://caymannewsservice.com/wp-content/plugins/fl3r-feelbox/css/style-icons-classic.css?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//caymannewsservice.com/wp-content/cache/wpfc-minified/2mshqkiw/6hpnc.css" media="all"/>
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='likebtn_style-css'  href='https://caymannewsservice.com/wp-content/plugins/likebtn-like-button/public/css/style.css?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//caymannewsservice.com/wp-content/cache/wpfc-minified/30em846/6hpnc.css" media="all"/>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/10.7/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.7/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script src='//caymannewsservice.com/wp-content/cache/wpfc-minified/ee8m718j/6hpnc.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/fl3r-feelbox/js/ajax.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='my-ajax-request-js'></script> -->
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/fl3r-feelbox/js/easyXDM.min.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='feelbox-remote-js'></script> -->
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.7/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='likebtn_frontend-js-extra'>
/* <![CDATA[ */
var likebtn_eh_data = {"ajaxurl":"https:\/\/caymannewsservice.com\/wp-admin\/admin-ajax.php","security":"c93c607b3d"};
/* ]]> */
</script>
<script src='//caymannewsservice.com/wp-content/cache/wpfc-minified/qx94aon5/6hpnc.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/likebtn-like-button/public/js/frontend.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='likebtn_frontend-js'></script> -->
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear7.5/js/suckerfish-cat.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='suckerfish-cat-js'></script> -->
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear7.5/js/jquery.mobilemenu.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='mobilmenu-js'></script> -->
<!-- <script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear7.5/js/flexslider.js?ver=0cc16f1fa5e1695f83c4ab2536fdcba0' id='flexslider-js'></script> -->
<link rel="https://api.w.org/" href="https://caymannewsservice.com/wp-json/" /><link rel="alternate" type="application/json" href="https://caymannewsservice.com/wp-json/wp/v2/posts/101317" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://caymannewsservice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://caymannewsservice.com/wp-includes/wlwmanifest.xml" /> 

<link rel="canonical" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/" />
<link rel='shortlink' href='https://wp.me/p5dt3Z-qm9' />
<link rel="alternate" type="application/json+oembed" href="https://caymannewsservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaymannewsservice.com%2F2022%2F03%2Fdriver-badly-hurt-after-light-pole-collision%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://caymannewsservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaymannewsservice.com%2F2022%2F03%2Fdriver-badly-hurt-after-light-pole-collision%2F&#038;format=xml" />
<!-- feelbox -->
<script type="text/javascript">
		//<![CDATA[
		var feelboxAjax = {
		centralized: '',
		cors: '',
		ajaxurl: 'https://caymannewsservice.com/wp-admin/admin-ajax.php',
		token: '27c4eb9678',
				id: 101317,
		title: 'Driver badly hurt after light pole collision',
		url: 'https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/',
		sparkline: 'on',
		sortmoods: '',
		fl3rfeelboxtitle: 'How do you feel after reading this?',
		fl3rfeelboxshareyourvote: 'Share your vote!',
		fl3rfeelboxnothanks: 'No, thanks.',
		fl3rfeelboxstyleicons: 'classic',
		tweet: 'off'
		};
	
		</script>
<!-- feelbox -->
                       <style type="text/css">
              @media screen {
                    .printfriendly {
                       position: relative;
                        z-index: 1000;
                     margin: 
                        12px 12px 12px 12px                     ;
                  }
                  .printfriendly a, .printfriendly a:link, .printfriendly a:visited, .printfriendly a:hover, .printfriendly a:active {
                       font-weight: 600;
                      cursor: pointer;
                       text-decoration: none;
                     border: none;
                      -webkit-box-shadow: none;
                      -moz-box-shadow: none;
                     box-shadow: none;
                      outline:none;
                        font-size: 14px !important;
                        color: #3AAA11 !important;
                   }
                  .printfriendly.pf-alignleft {
                      float: left
                    }
                  .printfriendly.pf-alignright {
                     float: right;
                  }
                  .printfriendly.pf-aligncenter {
                        display: flex;
                     align-items: center;
                       justify-content: center;
                   }
              }
          }

         @media print {
             .printfriendly {
                   display: none;
             }
          }

         .pf-button-img {
               border: none;
              -webkit-box-shadow: none; 
             -moz-box-shadow: none; 
                box-shadow: none; 
             padding: 0; 
               margin: 0;
             display: inline; 
              vertical-align: middle;
            }
          
           img.pf-button-img + .pf-button-text {
              margin-left: 6px;
          }
        </style>

        <style type="text/css" id="pf-excerpt-styles">
          .pf-button.pf-button-excerpt {
              display: none;
           }
        </style>
                <style type='text/css'>img#wpstats{display:none}</style>
	
<!-- Alternate Stylesheet -->
<link href="https://caymannewsservice.com/wp-content/themes/wp-clear7.5/styles/default.css" rel="stylesheet" type="text/css" />

<!-- Custom Styles from Theme Setting Page -->
<style type="text/css">
body {font-family:Arial,Helvetica,sans-serif;color:#000000;}
#topnav {border-bottom:0} #wrap {padding:20px 30px 20px;border-width:2px;border-style:solid;border-color:#2f739c;box-shadow:0px 2px 5px rgba(100,100,100,.3);-moz-box-shadow:0px 2px 5px rgba(100,100,100,.3);-webkit-box-shadow:0px 2px 5px rgba(100,100,100,.3);margin:30px auto}
h1,h2,h3,h4,h5,h6,h7,#sitetitle .title {font-family:Calibri,Arial,sans-serif;font-weight:bold;}
h1,h2,h3,h4,h5,h6,h7,#sitetitle .title {font-weight:bold;}
.post-title a,.post-title a:link,.post-title a:visited {color:#2f739c !important;}
#sitetitle,#logo {float:left;width:49%;}
#sitetitle .title,#sitetitle .description {float:none;text-indent:-999em;position:absolute;display:none;left:-999em;}
#topnav,#topnav ul ul a {font-size:12pt;font-weight:bold;font-family:Calibri,Arial,sans-serif;background:#2f739c;}
#topnav ul a,#topnav ul ul a {color:#ffffff;}
#topnav ul a:hover,#topnav ul ul a:hover {color:#000000;}
#topnav ul a:hover,#topnav ul ul a:hover {background-color:#c0c2c0;}
#catnav,#catnav ul ul a {font-size:10pt;font-weight:bold;font-family:Calibri,Arial,sans-serif;}
.maincontent, #content {font-size:10pt;}
#contentright {font-size:10pt;}
a.comment-reply-link,a.comment-reply-link:link,a.comment-reply-link:visited,#commentform input#submit,.archive-tabs a,.archive-tabs a:link,.archive-tabs a:visited,a.more-link,a.more-link:link,a.more-link:visited,p.email-form .subbutton,#searchform #submitbutton {border-color:#f0f0f0;background-color:#f0f0f0;}
a.comment-reply-link,a.comment-reply-link:link,a.comment-reply-link:visited,#commentform input#submit,.archive-tabs a,.archive-tabs a:link,.archive-tabs a:visited,a.more-link,a.more-link:link,a.more-link:visited,p.email-form .subbutton,#searchform #submitbutton {color:#9c050f !important;}
#footer {font-size:12pt;}
</style>

<!-- Styles from custom.css -->
<link href="https://caymannewsservice.com/wp-content/themes/wp-clear7.5/custom.css" rel="stylesheet" type="text/css" />

	<!-- MobileMenu JS -->
	<script type="text/javascript">
		jQuery(function () {
			jQuery('.nav').mobileMenu({ defaultText: 'Navigate to ...' });
			jQuery('.catnav').mobileMenu({ defaultText: 'Navigate to ... ', className: 'select-menu-catnav' });
		});
	</script>

	<!-- Media Queries Script for IE8 and Older -->
	<!--[if lt IE 9]>
		<script type="text/javascript" src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
	<![endif]-->
<meta name="description" content="(CNS): A man was taken to hospital in the early hours of Thursday morning with serious injuries after the vehicle he was driving crashed into a light pole on Mangrove Avenue in Prospect at about 3am. Police said the vehicle was travelling north when it veered off the roadway into a fence and then collided&hellip;" />
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Driver badly hurt after light pole collision  - Cayman Islands Headline News" />
<meta property="og:url" content="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/" />
<meta property="og:description" content="(CNS): A man was taken to hospital in the early hours of Thursday morning with serious injuries after the vehicle he was driving crashed into a light pole on Mangrove Avenue in Prospect at about 3a…" />
<meta property="article:published_time" content="2022-03-24T16:29:10+00:00" />
<meta property="article:modified_time" content="2022-03-24T16:29:15+00:00" />
<meta property="og:site_name" content="Cayman News Service" />
<meta property="og:image" content="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&#038;ssl=1" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Cayman News Service" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:creator" content="@CaymanNews" />
<meta name="twitter:site" content="@CaymanNews" />
<meta name="twitter:text:title" content="Driver badly hurt after light pole collision" />
<meta name="twitter:image" content="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&#038;ssl=1&#038;w=640" />
<meta name="twitter:image:alt" content="Cayman News Service" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon.png?fit=270%2C270&#038;ssl=1" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-2900728-1']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->


</head>

<body class="post-template-default single single-post postid-101317 single-format-standard c-sw">

<div class="outer-wrap">

			<div class="nav-wrapper">
			<div id="topnav">
				<div class="limit">
					<ul class="nav clearfix">
						<li id="menu-item-1586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1586"><a title="CNS rate sheet" href="https://caymannewsservice.com/rates/">Advertising Rates</a></li>
<li id="menu-item-1550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1550"><a title="CNS Comment Policy Basics" href="https://caymannewsservice.com/cns-comment-policy/">Comment Policy</a></li>
<li id="menu-item-5408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5408"><a href="http://eepurl.com/bHEp">Sign up for CNS Newsletter</a></li>
<li id="menu-item-83987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83987"><a href="https://caymannewsservice.com/tipbox/">Donate</a></li>
						<li class="rss-comments"><a title="Comments RSS Feed" href="https://caymannewsservice.com/comments/feed/">Comments</a></li>
						<li class="rss-content"><a title="Posts RSS Feed" href="https://caymannewsservice.com/feed/">Posts</a></li>
					</ul>
				</div>
			</div>
		</div>
	
	<div id="wrap">

		<div id="header">
			<div id="head-content" class="clearfix">
									<div id="logo">
						<a href="https://caymannewsservice.com" title="Cayman News Service"><img src="https://caymannewsservice.com/wp-content/uploads/2018/01/CNS-logo-cayman-ball-550-x-110.png" alt="Cayman News Service" /></a>
					</div>
								<div class="head-banner468">
	        <script type="text/javascript">
            var imagesArray623cb13b0f981 = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/10/Fidelity-under-new-management-ad.jpg?fit=450%2C100&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/10/Maples-rachel.png?fit=451%2C100&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/10/Quayside-surveyors.gif?fit=450%2C100&ssl=1");
            var linkArray623cb13b0f981 = new Array("https://www.fidelitygroup.com/caymanislands/fidelity-bank-announces-completion-of-share-purchase-agreement-with-proven-investments-limited", "https://maples.com/en/careers/students-and-graduates?utm_campaign=2022_navigate&utm_source=caymannewsservice&utm_medium=banner&utm_content=ncq", "https://www.quaysidesurveyors.ky/");
            var altArray623cb13b0f981 = new Array("", "", "");
            var idArray623cb13b0f981 = new Array("100440", "101262", "76647");
            var indexArray623cb13b0f981 = new Array("0", "1", "2");
            var currentAd623cb13b0f981 = 2;
            var imgCt623cb13b0f981 = 3;
            function cycle623cb13b0f981() {
                if (currentAd623cb13b0f981 == imgCt623cb13b0f981) {
                    currentAd623cb13b0f981 = 0;
                }
                var banner623cb13b0f981 = document.getElementById('adBanner623cb13b0f981');
                var link623cb13b0f981 = document.getElementById('adLink623cb13b0f981');
                banner623cb13b0f981.src = imagesArray623cb13b0f981[currentAd623cb13b0f981];
                banner623cb13b0f981.alt = idArray623cb13b0f981[currentAd623cb13b0f981];
                banner623cb13b0f981.title = altArray623cb13b0f981[currentAd623cb13b0f981];
                jQuery('#adBanner623cb13b0f981').attr("cur_index",indexArray623cb13b0f981[currentAd623cb13b0f981]);
                document.getElementById('adLink623cb13b0f981').href = linkArray623cb13b0f981[currentAd623cb13b0f981];            currentAd623cb13b0f981++;
            }
            window.setInterval("cycle623cb13b0f981()", 6000);
            if( "19" == '12447'){
            	console.log('Interval is ' + 6000 + ' miliseconds for id : '+ "623cb13b0f981");
            }
        </script>
        <a target="_blank" href="https://maples.com/en/careers/students-and-graduates?utm_campaign=2022_navigate&utm_source=caymannewsservice&utm_medium=banner&utm_content=ncq"  class="banner-poster" id="adLink623cb13b0f981" target="_top">
            <img title="" cur_index="1" class="banner-add" advert="19" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/10/Maples-rachel.png?fit=451%2C100&ssl=1" alt="101262" id="adBanner623cb13b0f981" border="0">
        </a>
        </div>
			</div>
		</div>


					<div class="nav-wrapper_cat">
				<div id="catnav">
					<ul class="catnav clearfix">
						<li id="menu-item-98" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-98"><a title="Cayman News Service" href="https://caymannewsservice.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93"><a href="https://caymannewsservice.com/category/politics/">Politics</a></li>
	<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="https://caymannewsservice.com/category/crime/">Crime</a></li>
	<li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-92"><a href="https://caymannewsservice.com/category/local-news/">Local News</a></li>
	<li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="https://caymannewsservice.com/category/health/">Health</a></li>
	<li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://caymannewsservice.com/category/science-nature/">Science &amp; Nature</a></li>
	<li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://caymannewsservice.com/category/world-news/">World News</a></li>
	<li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-96"><a title="Commentary" href="https://caymannewsservice.com/category/viewpoint/">Viewpoint</a>
	<ul class="sub-menu">
		<li id="menu-item-11749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11749"><a href="https://caymannewsservice.com/about-cns-viewpoints/">About CNS Viewpoints</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-84157" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84157"><a href="https://caymannewsservice.com/elections2021">2021 Election Section</a></li>
<li id="menu-item-26517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-26517"><a href="http://archive.caymannewsservice.com/">CNS Archives</a>
<ul class="sub-menu">
	<li id="menu-item-26518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26518"><a href="http://archive.caymannewsservice.com/">News Archives 2008-2014</a></li>
	<li id="menu-item-1809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1809"><a title="Cayman Islands Sports and community News" href="https://cnslocallife.com/">Local Life</a>
	<ul class="sub-menu">
		<li id="menu-item-13210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13210"><a href="https://cnslocallife.com/category/ask-auntie/">Ask Auntie</a></li>
		<li id="menu-item-13209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13209"><a href="https://cnsbusiness.com/category/goldenspoons/">Golden Spoons Restaurant Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-99" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99"><a title="Business News Archives" href="http://cnsbusiness.com/">CNS Business 2015-2017</a></li>
	<li id="menu-item-16179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16179"><a href="https://caymannewsservice.com/elections2017">2017 Elections</a></li>
</ul>
</li>
<li id="menu-item-13212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13212"><a title="Documents and Information Portal" href="http://cnslibrary.com">CNS Library</a></li>
<li id="menu-item-84160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84160"><a href="https://caymannewsservice.com/contact-us/">Contact Us</a></li>
						<li class="search"><form id="searchform" method="get" action="https://caymannewsservice.com/" ><input type="text" value="Enter Search Terms" onfocus="if (this.value == 'Enter Search Terms') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Enter Search Terms';}" size="18" maxlength="50" name="s" id="searchfield" /><input type="submit" value="search" id="submitbutton" /></form>
</li>
					</ul>
				</div>
			</div>
		
		
<div class="banner728-container clearfix">
	<div class="banner728 left">
		        <script type="text/javascript">
            var imagesArray623cb13b11b1d = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Doctors-Express.png?fit=728%2C90&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/RICS-Conference_CNS-Banner.png?fit=728%2C90&ssl=1");
            var linkArray623cb13b11b1d = new Array("https://www.doctorsexpress.ky/", "https://www.eventbrite.com/e/rics-cayman-conference-2022-tickets-262415881967");
            var altArray623cb13b11b1d = new Array("", "");
            var idArray623cb13b11b1d = new Array("75822", "101152");
            var indexArray623cb13b11b1d = new Array("0", "1");
            var currentAd623cb13b11b1d = 2;
            var imgCt623cb13b11b1d = 2;
            function cycle623cb13b11b1d() {
                if (currentAd623cb13b11b1d == imgCt623cb13b11b1d) {
                    currentAd623cb13b11b1d = 0;
                }
                var banner623cb13b11b1d = document.getElementById('adBanner623cb13b11b1d');
                var link623cb13b11b1d = document.getElementById('adLink623cb13b11b1d');
                banner623cb13b11b1d.src = imagesArray623cb13b11b1d[currentAd623cb13b11b1d];
                banner623cb13b11b1d.alt = idArray623cb13b11b1d[currentAd623cb13b11b1d];
                banner623cb13b11b1d.title = altArray623cb13b11b1d[currentAd623cb13b11b1d];
                jQuery('#adBanner623cb13b11b1d').attr("cur_index",indexArray623cb13b11b1d[currentAd623cb13b11b1d]);
                document.getElementById('adLink623cb13b11b1d').href = linkArray623cb13b11b1d[currentAd623cb13b11b1d];            currentAd623cb13b11b1d++;
            }
            window.setInterval("cycle623cb13b11b1d()", 10000);
            if( "33" == '12447'){
            	console.log('Interval is ' + 10000 + ' miliseconds for id : '+ "623cb13b11b1d");
            }
        </script>
        <a target="_blank" href="https://www.eventbrite.com/e/rics-cayman-conference-2022-tickets-262415881967"  class="banner-poster" id="adLink623cb13b11b1d" target="_top">
            <img title="" cur_index="1" class="banner-add" advert="33" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/RICS-Conference_CNS-Banner.png?fit=728%2C90&ssl=1" alt="101152" id="adBanner623cb13b11b1d" border="0">
        </a>
        	</div>
		
	<div class="banner220">
		        <script type="text/javascript">
            var imagesArray623cb13b122c6 = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Butterfield-220-jan-2022.gif?fit=220%2C90&ssl=1");
            var linkArray623cb13b122c6 = new Array("https://www.butterfieldgroup.com/en-ky");
            var altArray623cb13b122c6 = new Array("");
            var idArray623cb13b122c6 = new Array("99422");
            var indexArray623cb13b122c6 = new Array("0");
            var currentAd623cb13b122c6 = 1;
            var imgCt623cb13b122c6 = 1;
            function cycle623cb13b122c6() {
                if (currentAd623cb13b122c6 == imgCt623cb13b122c6) {
                    currentAd623cb13b122c6 = 0;
                }
                var banner623cb13b122c6 = document.getElementById('adBanner623cb13b122c6');
                var link623cb13b122c6 = document.getElementById('adLink623cb13b122c6');
                banner623cb13b122c6.src = imagesArray623cb13b122c6[currentAd623cb13b122c6];
                banner623cb13b122c6.alt = idArray623cb13b122c6[currentAd623cb13b122c6];
                banner623cb13b122c6.title = altArray623cb13b122c6[currentAd623cb13b122c6];
                jQuery('#adBanner623cb13b122c6').attr("cur_index",indexArray623cb13b122c6[currentAd623cb13b122c6]);
                document.getElementById('adLink623cb13b122c6').href = linkArray623cb13b122c6[currentAd623cb13b122c6];            currentAd623cb13b122c6++;
            }
            window.setInterval("cycle623cb13b122c6()", 12000);
            if( "36" == '12447'){
            	console.log('Interval is ' + 12000 + ' miliseconds for id : '+ "623cb13b122c6");
            }
        </script>
        <a target="_blank" href="https://www.butterfieldgroup.com/en-ky"  class="banner-poster" id="adLink623cb13b122c6" target="_top">
            <img title="" cur_index="0" class="banner-add" advert="36" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Butterfield-220-jan-2022.gif?fit=220%2C90&ssl=1" alt="99422" id="adBanner623cb13b122c6" border="0">
        </a>
        	</div>
	</div>


		<div id="page" class="clearfix">

			<div class="page-border clearfix">


				<div id="contentleft" class="clearfix">


					<div id="content" class="clearfix">

						
						<div class="banner468">
	        <script type="text/javascript">
            var imagesArray623cb13b12846 = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/11/Vampt-Dec-2021.jpg?fit=550%2C100&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/11/Home-gas-CUC-2.gif?fit=550%2C100&ssl=1");
            var linkArray623cb13b12846 = new Array("https://www.toyotacayman.com/listings/toyota-one/", "https://www.facebook.com/homegas");
            var altArray623cb13b12846 = new Array("Vampt Motors", "Home Gas");
            var idArray623cb13b12846 = new Array("98437", "66575");
            var indexArray623cb13b12846 = new Array("0", "1");
            var currentAd623cb13b12846 = 2;
            var imgCt623cb13b12846 = 2;
            function cycle623cb13b12846() {
                if (currentAd623cb13b12846 == imgCt623cb13b12846) {
                    currentAd623cb13b12846 = 0;
                }
                var banner623cb13b12846 = document.getElementById('adBanner623cb13b12846');
                var link623cb13b12846 = document.getElementById('adLink623cb13b12846');
                banner623cb13b12846.src = imagesArray623cb13b12846[currentAd623cb13b12846];
                banner623cb13b12846.alt = idArray623cb13b12846[currentAd623cb13b12846];
                banner623cb13b12846.title = altArray623cb13b12846[currentAd623cb13b12846];
                jQuery('#adBanner623cb13b12846').attr("cur_index",indexArray623cb13b12846[currentAd623cb13b12846]);
                document.getElementById('adLink623cb13b12846').href = linkArray623cb13b12846[currentAd623cb13b12846];            currentAd623cb13b12846++;
            }
            window.setInterval("cycle623cb13b12846()", 10000);
            if( "26" == '12447'){
            	console.log('Interval is ' + 10000 + ' miliseconds for id : '+ "623cb13b12846");
            }
        </script>
        <a target="_blank" href="https://www.facebook.com/homegas"  class="banner-poster" id="adLink623cb13b12846" target="_top">
            <img title="Home Gas" cur_index="1" class="banner-add" advert="26" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2014/11/Home-gas-CUC-2.gif?fit=550%2C100&ssl=1" alt="66575" id="adBanner623cb13b12846" border="0">
        </a>
        </div>


						<div class="post" id="post-main-101317">

							<div class="entry">

								<h1 class="post-title single entry-title"><a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/" rel="bookmark" title="Permanent Link to Driver badly hurt after light pole collision">Driver badly hurt after light pole collision</a></h1>

								<div class="meta single">

	<span class="meta-author">
		<a href="https://caymannewsservice.com/author/wendy-ledger/" title="Posts by Cayman News" rel="author">Cayman News</a> | 
	</span> 

	<span class="meta-date">
		24/03/2022	</span> 

		<span class="meta-comments">
		 | <a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comments" rel="bookmark" title="Comments for Driver badly hurt after light pole collision">6 Comments</a>
	</span>
	 

</div>
								
								<div class="pf-content">
<div class="wp-block-image"><figure class="alignleft size-full is-resized"><a href="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?ssl=1"><img data-attachment-id="98323" data-permalink="https://caymannewsservice.com/accident-emergency-hospital/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&amp;ssl=1" data-orig-size="500,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Accident emergency hospital" data-image-description data-image-caption="&lt;p&gt;Cayman Islands Hospital A&#038;E&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=300%2C240&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&amp;ssl=1" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?resize=250%2C200&#038;ssl=1" alt="Cayman News Service" class="wp-image-98323 jetpack-lazy-image" width="250" height="200" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?w=500&amp;ssl=1 500w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?resize=300%2C240&amp;ssl=1 300w" data-lazy-sizes="(max-width: 250px) 100vw, 250px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?resize=250%2C200&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="98323" data-permalink="https://caymannewsservice.com/accident-emergency-hospital/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&amp;ssl=1" data-orig-size="500,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Accident emergency hospital" data-image-description="" data-image-caption="&lt;p&gt;Cayman Islands Hospital A&#038;E&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=300%2C240&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?fit=500%2C400&amp;ssl=1" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?resize=250%2C200&#038;ssl=1" alt="Cayman News Service" class="wp-image-98323" width="250" height="200" srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?w=500&amp;ssl=1 500w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/12/Accident-emergency-hospital.jpg?resize=300%2C240&amp;ssl=1 300w" sizes="(max-width: 250px) 100vw, 250px" data-recalc-dims="1" /></noscript></a></figure></div>



<p>(CNS): A man was taken to hospital in the early hours of Thursday morning with serious injuries after the vehicle he was driving crashed into a light pole on Mangrove Avenue in Prospect at about 3am. Police said the vehicle was travelling north when it veered off the roadway into a fence and then collided with the utility pole, cutting power to many residents. </p>



<span id="more-101317"></span>



<p>No other vehicles were involved and the driver was the only occupant. He remains at the George Town Hospital, where he is undergoing treatment. The road was closed during the morning commute in the busy community as police carried out investigations.</p>



<p>The crash comes less than two weeks after another a man in a BMW was trapped and badly injured after hitting a light-pole on <a href="https://caymannewsservice.com/2022/03/driver-trapped-after-smashing-into-light-pole/"><strong>Walkers Road</strong></a> and less than a month after the driver of a black Honda was killed when his car collided with a fence column on <strong><a rel="noreferrer noopener" href="https://caymannewsservice.com/2022/02/fatal-road-accident-in-prospect/" target="_blank">Mangrove Avenue</a></strong>, the street parallel to today&#8217;s smash. </p>



<p>Four people have already been killed on Cayman roads this year and several more have been badly hurt as a result of the significant number of collisions every day.</p>



<hr class="wp-block-separator"/>



<div id="feelbox-widget" class="voted"><div id="lyr2"><div id="feelbox-bold">
		Share your vote!
		</div> 
		<BR>
		<BR>
		<div>
		<ul class="share-list">
		<li>
		    <a id="feelbox-twitter-button" class="socialmedia" href="https://twitter.com/share?url=https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/&related=Armando_Fiore&hashtags=FL3RFeelBox&text=I%20just%20voted%20on%20the%20post%20\"Driver badly hurt after light pole collision\""> </a> 
		</li>
		<li>
 	        <a id="feelbox-facebook-button" class="socialmedia" href="http://www.facebook.com/sharer/sharer.php?s=100&p[title]=Driver badly hurt after light pole collision&p[url]=https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/&p[summary]=I+just+voted+on+this+post+with+feelbox!"> </a> 
 		</li>
		<li>
 	        <a id="feelbox-linkedin-button" class="socialmedia" href="https://www.linkedin.com/cws/share?url=https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/"> </a>
		</li>
		<li>
 	        <a id="feelbox-pinterest-button" class="socialmedia" href="http://pinterest.com/pin/create/button/?url=https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/"> </a>
		</li>
		<li>
 	        <a id="feelbox-whatsapp-button" class="socialmedia" href="whatsapp://send?text=https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/"> </a>
		</li>
		</ul>
 		</div> 
 		 
 		<div id="feelbox-s"><a href="#" id="clr"><i class="fa fa-times-circle-o"></i>
		No, thanks.
		</a></div></div> 

			<div id="lyr1"></div>
			<div id="hdr">
				 <!-- 
 	            <div id="paypal"><a target="_blank" href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2PCZCTKZ86ANA" title="Donate with PayPal"><span> </span></a></div> 
 	            --!> 
 	                <div id="title"> 
 		                    <a target="_blank" href="https://wordpress.org/plugins/fl3r-feelbox/" title="FL3R FeelBox on Wordpress.org"><span> </span></a> 
				</div>
				         <div id="feelbox-title">
						 How do you feel after reading this?
						 </div> 
			</div>
			<span id="total"></span><span id="voted"></span>
			<div id="bd" style="">
				<div id="loading" style="display: block;"></div>
				
				<div id="sparkbardiv" style="">
					<div class="sparkbar" style="">
					</div>
				</div>
							
				<ul>
					<li id="mdr-e1"><div id="feelbox-cell"><div> 
						<span class="m">Fascinated</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
					 <li id="mdr-e2"><div id="feelbox-cell"><div> 
						<span class="m">Happy</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
					<li id="mdr-e3"><div id="feelbox-cell"><div> 
						<span class="m">Sad</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
					 <li id="mdr-e4"><div id="feelbox-cell"><div> 
						<span class="m">Angry</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
					<li id="mdr-e5"><div id="feelbox-cell"><div> 
						<span class="m">Bored</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
					<li id="mdr-e6"><div id="feelbox-cell"><div> 
						<span class="m">Afraid</span>
						<span class="count"></span><span class="percent"></span>
					</div></div></li>
				</ul>
			</div>
		</div>
<div class="printfriendly pf-button pf-button-content pf-alignleft"><a href="#" rel="nofollow" onClick="window.print(); return false;" title="Printer Friendly, PDF & Email"><img class="pf-button-img jetpack-lazy-image" src="https://i0.wp.com/cdn.printfriendly.com/buttons/printfriendly-pdf-email-button.png?ssl=1" alt="Print Friendly, PDF &amp; Email" style="width: 170px;height: 24px;" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/cdn.printfriendly.com/buttons/printfriendly-pdf-email-button.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="pf-button-img" src="https://i0.wp.com/cdn.printfriendly.com/buttons/printfriendly-pdf-email-button.png?ssl=1" alt="Print Friendly, PDF & Email" style="width: 170px;height: 24px;"  data-recalc-dims="1" /></noscript></a></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-101317" class="share-facebook sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-101317" class="share-twitter sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-101317" class="share-linkedin sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-101317" class="share-pinterest sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-101317" class="share-skype sd-button share-icon no-text" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
								<div style="clear:both;"></div>

								
								<p class="tags"><strong>Tags: </strong> <a href="https://caymannewsservice.com/tag/road-accident/" rel="tag">road accident</a></p>								<p class="cats"><strong>Category</strong>: <a href="https://caymannewsservice.com/category/local-news/" rel="category tag">Local News</a></p>

							</div>

						</div>

						
						
						
<!-- You can start editing here. -->

<div id="comments">

	<div class="allcomments">

	
		<h3 id="comments-title">Comments (6)</h3>

		<p class="comments-number"><a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/trackback/" title="Trackback URL">Trackback URL</a> | <a title="Comments RSS Feed for This Entry" href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/feed">Comments RSS Feed</a></p>

		<div class="comments-navigation clearfix">
			<div class="alignleft"></div>
			<div class="alignright"></div>
		</div>

		
		<ol class="commentlist">
					<li class="comment even thread-even depth-1" id="comment-519168">
				<div id="div-comment-519168" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Anonymous</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519168">24/03/2022 at 12:54 pm</a>		</div>

		<p>I hate it when those stupid lights poles jump in from of cars. Can&#8217;t the CIG do something?</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519168"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519168"  data-item_title="I hate it when those stupid lights poles jump in from of cars. Can't the CIG do something?"  data-item_date="2022-03-24T12:54:54-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519168#respond' data-commentid="519168" data-postid="101317" data-belowelement="div-comment-519168" data-respondelement="respond" data-replyto="Reply to Anonymous" aria-label='Reply to Anonymous'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-519167">
				<div id="div-comment-519167" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Colford Scott</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519167">24/03/2022 at 12:51 pm</a>		</div>

		<p>This is the same street, Mangrove Avenue, on which the fatal accident occurred last month. The MP for Prospect arranged for a number of speed humps to be installed on this road shortly after that accident.<br />
Slow Down and Drive Safely.</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519167"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519167"  data-item_title="This is the same street, Mangrove Avenue, on which the fatal accident occurred last month. The MP fo..."  data-item_date="2022-03-24T12:51:01-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519167#respond' data-commentid="519167" data-postid="101317" data-belowelement="div-comment-519167" data-respondelement="respond" data-replyto="Reply to Colford Scott" aria-label='Reply to Colford Scott'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="comment-519165">
				<div id="div-comment-519165" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Anonymous</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519165">24/03/2022 at 12:42 pm</a>		</div>

		<p>I do hope they are so badly injured they&#8217;ll never be able to operate a vehicle again. When I lost my son to a reckless driver he never offered up an apology and is driving to this day.</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519165"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519165"  data-item_title="I do hope they are so badly injured they'll never be able to operate a vehicle again. When I lost my..."  data-item_date="2022-03-24T12:42:24-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519165#respond' data-commentid="519165" data-postid="101317" data-belowelement="div-comment-519165" data-respondelement="respond" data-replyto="Reply to Anonymous" aria-label='Reply to Anonymous'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-519160">
				<div id="div-comment-519160" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Anonymous</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519160">24/03/2022 at 12:34 pm</a>		</div>

		<p>Avoiding the new speed bumps, perhaps?</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519160"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519160"  data-item_title="Avoiding the new speed bumps, perhaps?"  data-item_date="2022-03-24T12:34:58-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519160#respond' data-commentid="519160" data-postid="101317" data-belowelement="div-comment-519160" data-respondelement="respond" data-replyto="Reply to Anonymous" aria-label='Reply to Anonymous'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment even thread-even depth-1" id="comment-519155">
				<div id="div-comment-519155" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Sharky</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519155">24/03/2022 at 12:04 pm</a>		</div>

		<p>I&#8217;m surprised that CUC don&#8217;t claim that the loss of hundreds of light poles each year are partly responsible for the high cost of their electricity.</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519155"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519155"  data-item_title="I'm surprised that CUC don't claim that the loss of hundreds of light poles each year are partly res..."  data-item_date="2022-03-24T12:04:20-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519155#respond' data-commentid="519155" data-postid="101317" data-belowelement="div-comment-519155" data-respondelement="respond" data-replyto="Reply to Sharky" aria-label='Reply to Sharky'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-519152">
				<div id="div-comment-519152" class="comment-body">
				<div class="comment-author vcard">
						<cite class="fn">Anonymous</cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata">
			<a href="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519152">24/03/2022 at 11:48 am</a>		</div>

		<p>Even though this challenging one was located behind a fence, we really ought to get some crews to concrete these public menace poles into the ground so they stop jumping out in front of cars.  Maybe get the NRA to build an armco fortress around each one&#8230;just so long as we don&#8217;t have to talk about addressing ritual impaired driving, or spank the absentee RCIPS, or get DCI to pull any liquor licenses.  Hope this person recovers sufficiently to make their own course correction.</p>
<div class="likebtn_container" style=""><!-- LikeBtn.com BEGIN --><span class="likebtn-wrapper"  data-identifier="comment_519152"  data-site_id="5f4583b86fd08b907aa5b80b"  data-theme="greenred"  data-ef_voting="wobble"  data-show_dislike_label="true"  data-lazy_load="true"  data-share_enabled="false"  data-counter_count="true"  data-loader_show="true"  data-white_label="true"  data-popup_disabled="true"  data-style=""  data-unlike_allowed=""  data-show_copyright=""  data-item_url="https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/#comment-519152"  data-item_title="Even though this challenging one was located behind a fence, we really ought to get some crews to co..."  data-item_date="2022-03-24T11:48:35-05:00"  data-engine="WordPress"  data-plugin_v="2.6.43"  data-prx="https://caymannewsservice.com/wp-admin/admin-ajax.php?action=likebtn_prx"  data-event_handler="likebtn_eh"></span><!-- LikeBtn.com END --></div>

		<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://caymannewsservice.com/2022/03/driver-badly-hurt-after-light-pole-collision/?replytocom=519152#respond' data-commentid="519152" data-postid="101317" data-belowelement="div-comment-519152" data-respondelement="respond" data-replyto="Reply to Anonymous" aria-label='Reply to Anonymous'>Reply</a></div>
				</div>
				</li><!-- #comment-## -->
		</ol>

	
	</div>

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/03/driver-badly-hurt-after-light-pole-collision/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://caymannewsservice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea autocomplete="new-password"  id="f6c5908192"  name="f6c5908192"   cols="45" rows="8" maxlength="65525" required="required"></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "adfdcad1dc0f9ae17bdc70ae3d9ab5e8" );document.getElementById("f6c5908192").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='101317' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7f576f2b19" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="185"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div>
						<div class="navigation clearfix">
	<div class="alignleft single">
		&laquo; <a href="https://caymannewsservice.com/2022/03/suspect-and-cop-hurt-in-arrest-scuffle/" rel="prev">Suspect and cop hurt in arrest scuffle</a>	</div>
	<div class="alignright single">
		<a href="https://caymannewsservice.com/2022/03/rubis-faces-prosecution-over-oil-tank-spill/" rel="next">Rubis faces prosecution over oil tank spill</a> &raquo;	</div>
</div>

					</div> <!-- End #content div -->

					
				</div> <!-- End #contentleft div -->


		<div id="contentright">

						<div id="sidebar" class="clearfix">
				<div id="advert-banner-widget-36" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1966f = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/RF-Bank-Trust-dec-2021.png?fit=320%2C180&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/HCCI_PCR-tests.gif?fit=320%2C180&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/24-hour-truck-gif.gif?fit=320%2C180&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/WORC_JobsCayman-Listing-Print-Campaign.jpg?fit=320%2C180&ssl=1");
            var linkArray623cb13b1966f = new Array("https://www.rfgroup.com/superpossibilities", "https://www.healthcitycaymanislands.com/pcr-testing/", "http://www.industrialservices.ky/", "https://www.worc.ky/");
            var altArray623cb13b1966f = new Array("", "", "ISE", "");
            var idArray623cb13b1966f = new Array("97537", "96600", "18261", "100081");
            var indexArray623cb13b1966f = new Array("0", "1", "2", "3");
            var currentAd623cb13b1966f = 4;
            var imgCt623cb13b1966f = 4;
            function cycle623cb13b1966f() {
                if (currentAd623cb13b1966f == imgCt623cb13b1966f) {
                    currentAd623cb13b1966f = 0;
                }
                var banner623cb13b1966f = document.getElementById('adBanner623cb13b1966f');
                var link623cb13b1966f = document.getElementById('adLink623cb13b1966f');
                banner623cb13b1966f.src = imagesArray623cb13b1966f[currentAd623cb13b1966f];
                banner623cb13b1966f.alt = idArray623cb13b1966f[currentAd623cb13b1966f];
                banner623cb13b1966f.title = altArray623cb13b1966f[currentAd623cb13b1966f];
                jQuery('#adBanner623cb13b1966f').attr("cur_index",indexArray623cb13b1966f[currentAd623cb13b1966f]);
                document.getElementById('adLink623cb13b1966f').href = linkArray623cb13b1966f[currentAd623cb13b1966f];            currentAd623cb13b1966f++;
            }
            window.setInterval("cycle623cb13b1966f()", 6000);
            if( "37" == '12447'){
            	console.log('Interval is ' + 6000 + ' miliseconds for id : '+ "623cb13b1966f");
            }
        </script>
        <a target="_blank" href="https://www.worc.ky/"  class="banner-poster" id="adLink623cb13b1966f" target="_top">
            <img title="" cur_index="3" class="banner-add" advert="37" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/WORC_JobsCayman-Listing-Print-Campaign.jpg?fit=320%2C180&ssl=1" alt="100081" id="adBanner623cb13b1966f" border="0">
        </a>
        </div></div><div id="advert-banner-widget-41" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1a42f = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Wok-n-Roll-July-2020.gif?fit=320%2C180&ssl=1");
            var linkArray623cb13b1a42f = new Array("http://woknroll.ky/");
            var altArray623cb13b1a42f = new Array("");
            var idArray623cb13b1a42f = new Array("76017");
            var indexArray623cb13b1a42f = new Array("0");
            var currentAd623cb13b1a42f = 1;
            var imgCt623cb13b1a42f = 1;
            function cycle623cb13b1a42f() {
                if (currentAd623cb13b1a42f == imgCt623cb13b1a42f) {
                    currentAd623cb13b1a42f = 0;
                }
                var banner623cb13b1a42f = document.getElementById('adBanner623cb13b1a42f');
                var link623cb13b1a42f = document.getElementById('adLink623cb13b1a42f');
                banner623cb13b1a42f.src = imagesArray623cb13b1a42f[currentAd623cb13b1a42f];
                banner623cb13b1a42f.alt = idArray623cb13b1a42f[currentAd623cb13b1a42f];
                banner623cb13b1a42f.title = altArray623cb13b1a42f[currentAd623cb13b1a42f];
                jQuery('#adBanner623cb13b1a42f').attr("cur_index",indexArray623cb13b1a42f[currentAd623cb13b1a42f]);
                document.getElementById('adLink623cb13b1a42f').href = linkArray623cb13b1a42f[currentAd623cb13b1a42f];            currentAd623cb13b1a42f++;
            }
            window.setInterval("cycle623cb13b1a42f()", 6000);
            if( "39" == '12447'){
            	console.log('Interval is ' + 6000 + ' miliseconds for id : '+ "623cb13b1a42f");
            }
        </script>
        <a target="_blank" href="http://woknroll.ky/"  class="banner-poster" id="adLink623cb13b1a42f" target="_top">
            <img title="" cur_index="0" class="banner-add" advert="39" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Wok-n-Roll-July-2020.gif?fit=320%2C180&ssl=1" alt="76017" id="adBanner623cb13b1a42f" border="0">
        </a>
        </div></div><div id="advert-banner-widget-37" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1a92d = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Seaboard-marine-2022.jpg?fit=320%2C75&ssl=1");
            var linkArray623cb13b1a92d = new Array("https://www.seaboardmarine.com/grand-cayman/");
            var altArray623cb13b1a92d = new Array("Seaboard Marine");
            var idArray623cb13b1a92d = new Array("98743");
            var indexArray623cb13b1a92d = new Array("0");
            var currentAd623cb13b1a92d = 1;
            var imgCt623cb13b1a92d = 1;
            function cycle623cb13b1a92d() {
                if (currentAd623cb13b1a92d == imgCt623cb13b1a92d) {
                    currentAd623cb13b1a92d = 0;
                }
                var banner623cb13b1a92d = document.getElementById('adBanner623cb13b1a92d');
                var link623cb13b1a92d = document.getElementById('adLink623cb13b1a92d');
                banner623cb13b1a92d.src = imagesArray623cb13b1a92d[currentAd623cb13b1a92d];
                banner623cb13b1a92d.alt = idArray623cb13b1a92d[currentAd623cb13b1a92d];
                banner623cb13b1a92d.title = altArray623cb13b1a92d[currentAd623cb13b1a92d];
                jQuery('#adBanner623cb13b1a92d').attr("cur_index",indexArray623cb13b1a92d[currentAd623cb13b1a92d]);
                document.getElementById('adLink623cb13b1a92d').href = linkArray623cb13b1a92d[currentAd623cb13b1a92d];            currentAd623cb13b1a92d++;
            }
            window.setInterval("cycle623cb13b1a92d()", 15000);
            if( "46" == '12447'){
            	console.log('Interval is ' + 15000 + ' miliseconds for id : '+ "623cb13b1a92d");
            }
        </script>
        <a target="_blank" href="https://www.seaboardmarine.com/grand-cayman/"  class="banner-poster" id="adLink623cb13b1a92d" target="_top">
            <img title="Seaboard Marine" cur_index="0" class="banner-add" advert="46" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Seaboard-marine-2022.jpg?fit=320%2C75&ssl=1" alt="98743" id="adBanner623cb13b1a92d" border="0">
        </a>
        </div></div><div id="advert-banner-widget-59" class="widget banner300"><div class="widget-wrap"></div></div><div id="advert-banner-widget-39" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1b05f = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Stick-and-stones-basic-purple-blue.png?fit=320%2C180&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Stick-and-Stones-room-Nov-25th.jpg?fit=320%2C180&ssl=1", "https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Sticks-whatsApp.png?fit=320%2C180&ssl=1");
            var linkArray623cb13b1b05f = new Array("http://sticksandstones.ky/", "http://sticksandstones.ky/", "http://sticksandstones.ky/");
            var altArray623cb13b1b05f = new Array("Sticks & Stones", "Sticks & Stones", "Sticks & Stones");
            var idArray623cb13b1b05f = new Array("74762", "81785", "61969");
            var indexArray623cb13b1b05f = new Array("0", "1", "2");
            var currentAd623cb13b1b05f = 1;
            var imgCt623cb13b1b05f = 3;
            function cycle623cb13b1b05f() {
                if (currentAd623cb13b1b05f == imgCt623cb13b1b05f) {
                    currentAd623cb13b1b05f = 0;
                }
                var banner623cb13b1b05f = document.getElementById('adBanner623cb13b1b05f');
                var link623cb13b1b05f = document.getElementById('adLink623cb13b1b05f');
                banner623cb13b1b05f.src = imagesArray623cb13b1b05f[currentAd623cb13b1b05f];
                banner623cb13b1b05f.alt = idArray623cb13b1b05f[currentAd623cb13b1b05f];
                banner623cb13b1b05f.title = altArray623cb13b1b05f[currentAd623cb13b1b05f];
                jQuery('#adBanner623cb13b1b05f').attr("cur_index",indexArray623cb13b1b05f[currentAd623cb13b1b05f]);
                document.getElementById('adLink623cb13b1b05f').href = linkArray623cb13b1b05f[currentAd623cb13b1b05f];            currentAd623cb13b1b05f++;
            }
            window.setInterval("cycle623cb13b1b05f()", 5000);
            if( "71" == '12447'){
            	console.log('Interval is ' + 5000 + ' miliseconds for id : '+ "623cb13b1b05f");
            }
        </script>
        <a target="_blank" href="http://sticksandstones.ky/"  class="banner-poster" id="adLink623cb13b1b05f" target="_top">
            <img title="Sticks & Stones" cur_index="0" class="banner-add" advert="71" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2015/01/Stick-and-stones-basic-purple-blue.png?fit=320%2C180&ssl=1" alt="74762" id="adBanner623cb13b1b05f" border="0">
        </a>
        </div></div><div id="advert-banner-widget-62" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1ba87 = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Rovida.png?fit=320%2C180&ssl=1");
            var linkArray623cb13b1ba87 = new Array("mailto:admin@rpmcayman.com");
            var altArray623cb13b1ba87 = new Array("");
            var idArray623cb13b1ba87 = new Array("100454");
            var indexArray623cb13b1ba87 = new Array("0");
            var currentAd623cb13b1ba87 = 1;
            var imgCt623cb13b1ba87 = 1;
            function cycle623cb13b1ba87() {
                if (currentAd623cb13b1ba87 == imgCt623cb13b1ba87) {
                    currentAd623cb13b1ba87 = 0;
                }
                var banner623cb13b1ba87 = document.getElementById('adBanner623cb13b1ba87');
                var link623cb13b1ba87 = document.getElementById('adLink623cb13b1ba87');
                banner623cb13b1ba87.src = imagesArray623cb13b1ba87[currentAd623cb13b1ba87];
                banner623cb13b1ba87.alt = idArray623cb13b1ba87[currentAd623cb13b1ba87];
                banner623cb13b1ba87.title = altArray623cb13b1ba87[currentAd623cb13b1ba87];
                jQuery('#adBanner623cb13b1ba87').attr("cur_index",indexArray623cb13b1ba87[currentAd623cb13b1ba87]);
                document.getElementById('adLink623cb13b1ba87').href = linkArray623cb13b1ba87[currentAd623cb13b1ba87];            currentAd623cb13b1ba87++;
            }
            window.setInterval("cycle623cb13b1ba87()", 6000);
            if( "65" == '12447'){
            	console.log('Interval is ' + 6000 + ' miliseconds for id : '+ "623cb13b1ba87");
            }
        </script>
        <a target="_blank" href="mailto:admin@rpmcayman.com"  class="banner-poster" id="adLink623cb13b1ba87" target="_top">
            <img title="" cur_index="0" class="banner-add" advert="65" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Rovida.png?fit=320%2C180&ssl=1" alt="100454" id="adBanner623cb13b1ba87" border="0">
        </a>
        </div></div><div id="bannerad-widget-2" class="widget bannerad"><div class="widget-wrap"><a href="https://www.accuweather.com/en/ky/george-town/53291/weather-forecast/53291" class="aw-widget-legal">
<!--
By accessing and/or using this code snippet, you agree to AccuWeather’s terms and conditions (in English) which can be found at https://www.accuweather.com/en/free-weather-widgets/terms and AccuWeather’s Privacy Statement (in English) which can be found at https://www.accuweather.com/en/privacy.
-->
</a><div id="awcc1530889340299" class="aw-widget-current"  data-locationkey="53291" data-unit="f" data-language="en-us" data-useip="false" data-uid="awcc1530889340299"></div><script type="text/javascript" src="https://oap.accuweather.com/launch.js"></script></div></div><div id="advert-banner-widget-63" class="widget banner300"><div class="widget-wrap">        <script type="text/javascript">
            var imagesArray623cb13b1bfb8 = new Array("https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/02/job-vacancy-CHILDREN-YOUTH-COORDINATOR.png?fit=320%2C180&ssl=1");
            var linkArray623cb13b1bfb8 = new Array("https://caymannewsservice.com/wp-content/uploads/2022/02/Job-Posting-CAYC-Feb.-2022.pdf");
            var altArray623cb13b1bfb8 = new Array("");
            var idArray623cb13b1bfb8 = new Array("99724");
            var indexArray623cb13b1bfb8 = new Array("0");
            var currentAd623cb13b1bfb8 = 1;
            var imgCt623cb13b1bfb8 = 1;
            function cycle623cb13b1bfb8() {
                if (currentAd623cb13b1bfb8 == imgCt623cb13b1bfb8) {
                    currentAd623cb13b1bfb8 = 0;
                }
                var banner623cb13b1bfb8 = document.getElementById('adBanner623cb13b1bfb8');
                var link623cb13b1bfb8 = document.getElementById('adLink623cb13b1bfb8');
                banner623cb13b1bfb8.src = imagesArray623cb13b1bfb8[currentAd623cb13b1bfb8];
                banner623cb13b1bfb8.alt = idArray623cb13b1bfb8[currentAd623cb13b1bfb8];
                banner623cb13b1bfb8.title = altArray623cb13b1bfb8[currentAd623cb13b1bfb8];
                jQuery('#adBanner623cb13b1bfb8').attr("cur_index",indexArray623cb13b1bfb8[currentAd623cb13b1bfb8]);
                document.getElementById('adLink623cb13b1bfb8').href = linkArray623cb13b1bfb8[currentAd623cb13b1bfb8];            currentAd623cb13b1bfb8++;
            }
            window.setInterval("cycle623cb13b1bfb8()", 10000);
            if( "2224" == '12447'){
            	console.log('Interval is ' + 10000 + ' miliseconds for id : '+ "623cb13b1bfb8");
            }
        </script>
        <a target="_blank" href="https://caymannewsservice.com/wp-content/uploads/2022/02/Job-Posting-CAYC-Feb.-2022.pdf"  class="banner-poster" id="adLink623cb13b1bfb8" target="_top">
            <img title="" cur_index="0" class="banner-add" advert="2224" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/02/job-vacancy-CHILDREN-YOUTH-COORDINATOR.png?fit=320%2C180&ssl=1" alt="99724" id="adBanner623cb13b1bfb8" border="0">
        </a>
        </div></div>			</div>
			

						<div id="sidebar-bottom" class="clearfix">
				<div id="sidebar-bottom-left">
					<div id="feelbox_widget-2" class="widget feelbox_widget"><div class="widget-wrap"><h3 class="widgettitle"><span>Most emotional posts on CNS over past week</span></h3><ul class="feelbox_widget-no-list"><li><a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101232" data-permalink="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/health-minister-sabrina-turner-18-march-2022/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Health Minister Sabrina Turner 18 March 2022" data-image-description="" data-image-caption="&lt;p&gt;Health Minister Sabrina Turner at the press briefing&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Health-Minister-Sabrina-Turner-18-March-2022.png?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/">Mask mandate to remain until end of April</li></a><li><a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101111" data-permalink="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/top-soil-and-fill-on-ebanks-family-farm-from-housing-site/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Top soil and fill on Ebanks family farm from housing site" data-image-description="" data-image-caption="&lt;p&gt;Top soil and fill on the Ebanks family farm&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Top-soil-and-fill-on-Ebanks-family-farm-from-housing-site.jpg?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/">Questions raised over &#8216;inside deal&#8217; for NHDT fill</li></a><li><a href="https://caymannewsservice.com/2022/03/panton-work-permit-imbalance-will-be-addressed/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101246" data-permalink="https://caymannewsservice.com/2022/03/panton-work-permit-imbalance-will-be-addressed/premier-wayne-panton-18-march-2022/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Premier Wayne Panton 18 March 2022" data-image-description="" data-image-caption="&lt;p&gt;Premier Wayne Panton at Friday&#8217;s press briefing&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Premier-Wayne-Panton-18-March-2022.png?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/panton-work-permit-imbalance-will-be-addressed/">Panton: Work permit imbalance will be addressed</li></a><li><a href="https://caymannewsservice.com/2022/03/disney-ship-triggers-phased-cruise-return/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101148" data-permalink="https://caymannewsservice.com/2022/03/disney-ship-triggers-phased-cruise-return/tourism-minister-kenneth-bryan-among-officials-welcoming-the-disney-magic/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Tourism Minister Kenneth Bryan among officials welcoming the Disney Magic" data-image-description="" data-image-caption="&lt;p&gt;Tourism Minister Kenneth Bryan among officials welcoming the Disney Magic on Monday (photo from MoT social media)&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Tourism-Minister-Kenneth-Bryan-among-officials-welcoming-the-Disney-Magic.jpg?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/disney-ship-triggers-phased-cruise-return/">Disney ship triggers phased cruise return</li></a><li><a href="https://caymannewsservice.com/2022/03/jubilee-tree-gains-lost-in-just-one-cpa-meeting/" title=""><img width="160" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?fit=160%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101301" data-permalink="https://caymannewsservice.com/2022/03/jubilee-tree-gains-lost-in-just-one-cpa-meeting/gab-mahogany-planting/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?fit=600%2C450&amp;ssl=1" data-orig-size="600,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="GAB Mahogany Planting" data-image-description="" data-image-caption="&lt;p&gt;Governor Martyn Roper and Premier Wayne Panton were among the officials at the tree planting at the GAB&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?fit=600%2C450&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?resize=400%2C300&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/GAB-Mahogany-Planting.jpg?fit=160%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/jubilee-tree-gains-lost-in-just-one-cpa-meeting/">Jubilee tree gains lost in just one CPA meeting</li></a><li><a href="https://caymannewsservice.com/2022/03/new-airport-road-delayed-over-culverts-tender/" title=""><img width="160" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?fit=160%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="74170" data-permalink="https://caymannewsservice.com/2020/05/roadworks-underway-while-island-under-curfew/nra-4-airport-connector/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?fit=600%2C450&amp;ssl=1" data-orig-size="600,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NRA 4 &#8211; Airport Connector" data-image-description="" data-image-caption="&lt;p&gt;Phase 1 of the Airport Connector Road extends between the Esterley Tibbetts&lt;br /&gt;
Highway and Sparky Drive&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?fit=600%2C450&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?resize=400%2C300&amp;ssl=1 400w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/05/NRA-4-Airport-Connector.jpg?fit=160%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/new-airport-road-delayed-over-culverts-tender/">New airport road delayed over culverts tender</li></a><li><a href="https://caymannewsservice.com/2022/03/premier-wants-input-on-planning-law-review/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="83289" data-permalink="https://caymannewsservice.com/watermark-construction-2/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="WaterMark construction 2" data-image-description="" data-image-caption="&lt;p&gt;WaterMark construction site in January 2021&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/01/WaterMark-construction-2.jpeg?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/premier-wants-input-on-planning-law-review/">Premier wants input on planning law review</li></a><li><a href="https://caymannewsservice.com/2022/03/hsa-teams-up-with-charity-to-help-sick-child/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="94576" data-permalink="https://caymannewsservice.com/2021/10/cal-adds-tampa-to-growing-flight-service/cayman-airways-side/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cayman Airways side" data-image-description="" data-image-caption="&lt;p&gt;Photo courtesy Cayman Airways Ltd&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2021/10/Cayman-Airways-side.jpg?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/hsa-teams-up-with-charity-to-help-sick-child/">HSA teams up with charity to help sick child</li></a><li><a href="https://caymannewsservice.com/2022/03/public-street-fitness-park-opens-on-7mb/" title=""><img width="180" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?fit=180%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101198" data-permalink="https://caymannewsservice.com/2022/03/public-street-fitness-park-opens-on-7mb/local-students-test-out-the-callisthenics-park/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?fit=600%2C400&amp;ssl=1" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Local students test out the Callisthenics Park" data-image-description="" data-image-caption="&lt;p&gt;Local students test out the Callisthenics Park&lt;/p&gt;
" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?fit=600%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?w=600&amp;ssl=1 600w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Local-students-test-out-the-Callisthenics-Park.jpg?fit=180%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/public-street-fitness-park-opens-on-7mb/">Public street fitness park opens on 7MB</li></a><li><a href="https://caymannewsservice.com/2022/03/food-truck-robbed-by-armed-cyclist/" title=""><img width="150" height="120" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?fit=150%2C120&amp;ssl=1" class="mdt-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" title="" data-attachment-id="101275" data-permalink="https://caymannewsservice.com/2022/03/food-truck-robbed-by-armed-cyclist/burger-shack-food-truck/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?fit=500%2C400&amp;ssl=1" data-orig-size="500,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Burger Shack food truck" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?fit=300%2C240&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?fit=500%2C400&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?w=500&amp;ssl=1 500w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?resize=300%2C240&amp;ssl=1 300w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/03/Burger-Shack-food-truck.jpg?fit=150%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><a href="https://caymannewsservice.com/2022/03/food-truck-robbed-by-armed-cyclist/">Food truck robbed by armed cyclist</li></a></ul></div></div><div id="media_image-4" class="widget widget_media_image"><div class="widget-wrap"><a href="https://caymannewsservice.com/tipbox/"><img width="175" height="200" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/11/Tip-Jar-for-CNS-175x200-1.gif?fit=175%2C200&amp;ssl=1" class="image wp-image-81517  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="81517" data-permalink="https://caymannewsservice.com/tip-jar-for-cns-175x200/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/11/Tip-Jar-for-CNS-175x200-1.gif?fit=175%2C200&amp;ssl=1" data-orig-size="175,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Tip Jar for CNS 175&#215;200" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/11/Tip-Jar-for-CNS-175x200-1.gif?fit=175%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/11/Tip-Jar-for-CNS-175x200-1.gif?fit=175%2C200&amp;ssl=1" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2020/11/Tip-Jar-for-CNS-175x200-1.gif?fit=175%2C200&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></div><div id="media_image-3" class="widget widget_media_image"><div class="widget-wrap"><a href="https://report.iwf.org.uk/ky"><img width="300" height="100" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?fit=300%2C100&amp;ssl=1" class="image wp-image-9778  attachment-medium size-medium jetpack-lazy-image" alt="child porn" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="9778" data-permalink="https://caymannewsservice.com/advertisement/iwf-child-porn/iwf-child-pornography/" data-orig-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?fit=320%2C107&amp;ssl=1" data-orig-size="320,107" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IWF &#8211; child pornography" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?fit=300%2C100&amp;ssl=1" data-large-file="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?fit=320%2C107&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?w=320&amp;ssl=1 320w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?resize=300%2C100&amp;ssl=1 300w, https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?resize=200%2C67&amp;ssl=1 200w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png?fit=300%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></div>				</div>
				<div id="sidebar-bottom-right">
					
    <div id="likebtnlikebuttonmostlikedwidget-2" class="widget widget_likebtnlikebuttonmostlikedwidget"><div class="widget-wrap">
            <h3 class="widgettitle"><span>    	Favourite comments over past week            </span></h3>    
	<ul class="likebtn-mlw">
			<li id="post-518284" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/disney-ship-triggers-phased-cruise-return/comment-page-1/#comment-518284" title="Tens of thousands of low spend cruisers can enter ...">
                                <div class="likebtn-mlw-title">
                    Tens of thousands of low spend cruisers can enter ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        135                                            /
                                        4                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517849" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517849" title="Further, it is alleged that Johnny Ebanks, the fat...">
                                <div class="likebtn-mlw-title">
                    Further, it is alleged that Johnny Ebanks, the fat...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        131                                            /
                                        1                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517965" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517965" title="Wanna see a joke, look at the appointments that ha...">
                                <div class="likebtn-mlw-title">
                    Wanna see a joke, look at the appointments that ha...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        115                                            /
                                        2                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517997" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517997" title="The latest money grab

Just look at the actions ...">
                                <div class="likebtn-mlw-title">
                    The latest money grab

Just look at the actions ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        114                                            /
                                        7                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518499" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/comment-page-1/#comment-518499" title="this &quot;health minister&quot; is too lazy to hit the gym ...">
                                <div class="likebtn-mlw-title">
                    this "health minister" is too lazy to hit the gym ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        114                                            /
                                        24                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518686" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/panton-work-permit-imbalance-will-be-addressed/comment-page-1/#comment-518686" title="At this point, there are so many vacancies, and em...">
                                <div class="likebtn-mlw-title">
                    At this point, there are so many vacancies, and em...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        110                                            /
                                        10                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517987" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517987" title="Allegedly, Minister Jay&#039;s father got all the NHT w...">
                                <div class="likebtn-mlw-title">
                    Allegedly, Minister Jay's father got all the NHT w...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        107                                            /
                                        4                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517951" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517951" title="Jay, another mini-McKeeva in the making

How do ...">
                                <div class="likebtn-mlw-title">
                    Jay, another mini-McKeeva in the making

How do ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        103                                            /
                                        2                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517802" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517802" title="Two questions for you:
(1)  Are there any honest ...">
                                <div class="likebtn-mlw-title">
                    Two questions for you:
(1)  Are there any honest ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        103                                            /
                                        3                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518256" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/disney-ship-triggers-phased-cruise-return/comment-page-1/#comment-518256" title="Unbelievable that we are forcing air arrivals to (...">
                                <div class="likebtn-mlw-title">
                    Unbelievable that we are forcing air arrivals to (...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        102                                            /
                                        0                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518010" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-518010" title="Over to you Wayne - Section 3.2 of the Ministerial...">
                                <div class="likebtn-mlw-title">
                    Over to you Wayne - Section 3.2 of the Ministerial...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        100                                            /
                                        2                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518500" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/comment-page-1/#comment-518500" title="&quot;Driven by political reasons&quot;??? So how exactly do...">
                                <div class="likebtn-mlw-title">
                    "Driven by political reasons"??? So how exactly do...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        99                                            /
                                        9                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517829" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517829" title="Having read this article, we will follow up on thi...">
                                <div class="likebtn-mlw-title">
                    Having read this article, we will follow up on thi...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        97                                            /
                                        1                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517786" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517786" title="No surprises here. The NHDT board is comprised of ...">
                                <div class="likebtn-mlw-title">
                    No surprises here. The NHDT board is comprised of ...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        93                                            /
                                        4                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517866" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517866" title="Isn&#039;t that a bit like when Mario was given the con...">
                                <div class="likebtn-mlw-title">
                    Isn't that a bit like when Mario was given the con...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        93                                            /
                                        0                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517962" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517962" title="Perhaps the general manager of the NHDT should als...">
                                <div class="likebtn-mlw-title">
                    Perhaps the general manager of the NHDT should als...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        89                                            /
                                        3                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518486" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/comment-page-1/#comment-518486" title="&quot;Premier Wayne Panton said that many countries are...">
                                <div class="likebtn-mlw-title">
                    "Premier Wayne Panton said that many countries are...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        89                                            /
                                        5                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-518478" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/mask-mandate-to-remain-until-end-of-april/comment-page-1/#comment-518478" title="I just walked into and straight out of Kirk Freepo...">
                                <div class="likebtn-mlw-title">
                    I just walked into and straight out of Kirk Freepo...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        88                                            /
                                        9                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517999" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517999" title="I have to say that when this country voted against...">
                                <div class="likebtn-mlw-title">
                    I have to say that when this country voted against...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        87                                            /
                                        21                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
			<li id="post-517852" class="likebtn-mlw-item" >
            <a href="https://caymannewsservice.com/2022/03/questions-raised-over-inside-deal-for-nhdt-fill/comment-page-1/#comment-517852" title="Someone needs to ask if it’s true that Minister Ja...">
                                <div class="likebtn-mlw-title">
                    Someone needs to ask if it’s true that Minister Ja...&nbsp;<span class="likebtn-item-likes"><nobr>(
                                        86                                            /
                                        2                                            )</nobr></span>
                                    </div>
            </a>
                                                            		</li>
		</ul>

    </div></div>				</div>
			</div>
			
		</div>


			</div> <!-- End .page-border div -->

		</div> <!-- End #page div -->

		
	</div> <!-- End #wrap div -->

		<div id="footer-widgets" class="maincontent">
		<div class="limit clearfix">
			<div class="footer-widget1">
				<div id="tag_cloud-2" class="widget widget_tag_cloud"><div class="widget-wrap"><h3 class="widgettitle"><span>Tags</span></h3><div class="tagcloud"><a href="https://caymannewsservice.com/tag/alden-mclaughlin/" class="tag-cloud-link tag-link-43 tag-link-position-1" style="font-size: 15.396226415094pt;" aria-label="Alden McLaughlin (721 items)">Alden McLaughlin</a>
<a href="https://caymannewsservice.com/tag/armed-robbery/" class="tag-cloud-link tag-link-155 tag-link-position-2" style="font-size: 10.641509433962pt;" aria-label="armed robbery (208 items)">armed robbery</a>
<a href="https://caymannewsservice.com/tag/ask-auntie/" class="tag-cloud-link tag-link-890 tag-link-position-3" style="font-size: 9.4088050314465pt;" aria-label="Ask Auntie (151 items)">Ask Auntie</a>
<a href="https://caymannewsservice.com/tag/burglary/" class="tag-cloud-link tag-link-505 tag-link-position-4" style="font-size: 9.7610062893082pt;" aria-label="burglary (164 items)">burglary</a>
<a href="https://caymannewsservice.com/tag/cayman-airways/" class="tag-cloud-link tag-link-182 tag-link-position-5" style="font-size: 8.1761006289308pt;" aria-label="Cayman Airways (108 items)">Cayman Airways</a>
<a href="https://caymannewsservice.com/tag/cayman-brac/" class="tag-cloud-link tag-link-113 tag-link-position-6" style="font-size: 8.6163522012579pt;" aria-label="Cayman Brac (121 items)">Cayman Brac</a>
<a href="https://caymannewsservice.com/tag/cayman-islands-fire-service/" class="tag-cloud-link tag-link-432 tag-link-position-7" style="font-size: 8.9685534591195pt;" aria-label="Cayman Islands Fire Service (133 items)">Cayman Islands Fire Service</a>
<a href="https://caymannewsservice.com/tag/central-planning-authority/" class="tag-cloud-link tag-link-577 tag-link-position-8" style="font-size: 8.7924528301887pt;" aria-label="Central Planning Authority (129 items)">Central Planning Authority</a>
<a href="https://caymannewsservice.com/tag/cns-business/" class="tag-cloud-link tag-link-228 tag-link-position-9" style="font-size: 9.7610062893082pt;" aria-label="CNS Business (164 items)">CNS Business</a>
<a href="https://caymannewsservice.com/tag/cns-local-life/" class="tag-cloud-link tag-link-327 tag-link-position-10" style="font-size: 10.993710691824pt;" aria-label="CNS Local Life (228 items)">CNS Local Life</a>
<a href="https://caymannewsservice.com/tag/coronavirus/" class="tag-cloud-link tag-link-2793 tag-link-position-11" style="font-size: 13.723270440252pt;" aria-label="coronavirus (472 items)">coronavirus</a>
<a href="https://caymannewsservice.com/tag/corruption/" class="tag-cloud-link tag-link-162 tag-link-position-12" style="font-size: 9.7610062893082pt;" aria-label="corruption (164 items)">corruption</a>
<a href="https://caymannewsservice.com/tag/covid-19/" class="tag-cloud-link tag-link-2833 tag-link-position-13" style="font-size: 16.012578616352pt;" aria-label="COVID-19 (845 items)">COVID-19</a>
<a href="https://caymannewsservice.com/tag/covid-19-vaccine/" class="tag-cloud-link tag-link-3013 tag-link-position-14" style="font-size: 10.553459119497pt;" aria-label="COVID-19 vaccine (205 items)">COVID-19 vaccine</a>
<a href="https://caymannewsservice.com/tag/cruise-dock-facility/" class="tag-cloud-link tag-link-477 tag-link-position-15" style="font-size: 12.578616352201pt;" aria-label="cruise dock facility (349 items)">cruise dock facility</a>
<a href="https://caymannewsservice.com/tag/cruise-port-referendum/" class="tag-cloud-link tag-link-2046 tag-link-position-16" style="font-size: 11.081761006289pt;" aria-label="Cruise Port Referendum (231 items)">Cruise Port Referendum</a>
<a href="https://caymannewsservice.com/tag/cuc/" class="tag-cloud-link tag-link-241 tag-link-position-17" style="font-size: 8.1761006289308pt;" aria-label="CUC (109 items)">CUC</a>
<a href="https://caymannewsservice.com/tag/department-of-environment/" class="tag-cloud-link tag-link-353 tag-link-position-18" style="font-size: 11.786163522013pt;" aria-label="Department of Environment (280 items)">Department of Environment</a>
<a href="https://caymannewsservice.com/tag/dr-john-lee/" class="tag-cloud-link tag-link-2577 tag-link-position-19" style="font-size: 8.6163522012579pt;" aria-label="Dr John Lee (121 items)">Dr John Lee</a>
<a href="https://caymannewsservice.com/tag/drug-crime/" class="tag-cloud-link tag-link-225 tag-link-position-20" style="font-size: 11.874213836478pt;" aria-label="drug crime (285 items)">drug crime</a>
<a href="https://caymannewsservice.com/tag/dwayne-seymour/" class="tag-cloud-link tag-link-1362 tag-link-position-21" style="font-size: 8.6163522012579pt;" aria-label="Dwayne Seymour (121 items)">Dwayne Seymour</a>
<a href="https://caymannewsservice.com/tag/ezzard-miller/" class="tag-cloud-link tag-link-88 tag-link-position-22" style="font-size: 11.522012578616pt;" aria-label="Ezzard Miller (264 items)">Ezzard Miller</a>
<a href="https://caymannewsservice.com/tag/fatality/" class="tag-cloud-link tag-link-56 tag-link-position-23" style="font-size: 11.786163522013pt;" aria-label="fatality (279 items)">fatality</a>
<a href="https://caymannewsservice.com/tag/featured/" class="tag-cloud-link tag-link-5 tag-link-position-24" style="font-size: 22pt;" aria-label="Featured (4,050 items)">Featured</a>
<a href="https://caymannewsservice.com/tag/franz-manderson/" class="tag-cloud-link tag-link-145 tag-link-position-25" style="font-size: 8.0880503144654pt;" aria-label="Franz Manderson (107 items)">Franz Manderson</a>
<a href="https://caymannewsservice.com/tag/gun-crime/" class="tag-cloud-link tag-link-52 tag-link-position-26" style="font-size: 12.22641509434pt;" aria-label="gun crime (318 items)">gun crime</a>
<a href="https://caymannewsservice.com/tag/jeff-webb/" class="tag-cloud-link tag-link-139 tag-link-position-27" style="font-size: 8.6163522012579pt;" aria-label="Jeff Webb (122 items)">Jeff Webb</a>
<a href="https://caymannewsservice.com/tag/kenneth-bryan/" class="tag-cloud-link tag-link-341 tag-link-position-28" style="font-size: 8.3522012578616pt;" aria-label="Kenneth Bryan (115 items)">Kenneth Bryan</a>
<a href="https://caymannewsservice.com/tag/martyn-roper/" class="tag-cloud-link tag-link-2140 tag-link-position-29" style="font-size: 9.1446540880503pt;" aria-label="Martyn Roper (141 items)">Martyn Roper</a>
<a href="https://caymannewsservice.com/tag/mckeeva-bush/" class="tag-cloud-link tag-link-40 tag-link-position-30" style="font-size: 10.553459119497pt;" aria-label="McKeeva Bush (201 items)">McKeeva Bush</a>
<a href="https://caymannewsservice.com/tag/moses-kirkconnell/" class="tag-cloud-link tag-link-143 tag-link-position-31" style="font-size: 8.7924528301887pt;" aria-label="Moses Kirkconnell (128 items)">Moses Kirkconnell</a>
<a href="https://caymannewsservice.com/tag/murder/" class="tag-cloud-link tag-link-57 tag-link-position-32" style="font-size: 8.6163522012579pt;" aria-label="murder (123 items)">murder</a>
<a href="https://caymannewsservice.com/tag/office-of-the-auditor-general/" class="tag-cloud-link tag-link-30 tag-link-position-33" style="font-size: 9.4088050314465pt;" aria-label="Office of the Auditor General (151 items)">Office of the Auditor General</a>
<a href="https://caymannewsservice.com/tag/public-accounts-committee/" class="tag-cloud-link tag-link-144 tag-link-position-34" style="font-size: 8.9685534591195pt;" aria-label="Public Accounts Committee (135 items)">Public Accounts Committee</a>
<a href="https://caymannewsservice.com/tag/rcips/" class="tag-cloud-link tag-link-39 tag-link-position-35" style="font-size: 8.8805031446541pt;" aria-label="RCIPS (131 items)">RCIPS</a>
<a href="https://caymannewsservice.com/tag/road-accident/" class="tag-cloud-link tag-link-55 tag-link-position-36" style="font-size: 13.106918238994pt;" aria-label="road accident (400 items)">road accident</a>
<a href="https://caymannewsservice.com/tag/roy-mctaggart/" class="tag-cloud-link tag-link-286 tag-link-position-37" style="font-size: 8.2641509433962pt;" aria-label="Roy McTaggart (111 items)">Roy McTaggart</a>
<a href="https://caymannewsservice.com/tag/sex-crimes/" class="tag-cloud-link tag-link-185 tag-link-position-38" style="font-size: 10.11320754717pt;" aria-label="sex crimes (183 items)">sex crimes</a>
<a href="https://caymannewsservice.com/tag/shooting/" class="tag-cloud-link tag-link-771 tag-link-position-39" style="font-size: 8pt;" aria-label="shooting (103 items)">shooting</a>
<a href="https://caymannewsservice.com/tag/stabbing/" class="tag-cloud-link tag-link-313 tag-link-position-40" style="font-size: 9.4088050314465pt;" aria-label="stabbing (150 items)">stabbing</a>
<a href="https://caymannewsservice.com/tag/tara-rivers/" class="tag-cloud-link tag-link-97 tag-link-position-41" style="font-size: 9.2327044025157pt;" aria-label="Tara Rivers (145 items)">Tara Rivers</a>
<a href="https://caymannewsservice.com/tag/theft/" class="tag-cloud-link tag-link-121 tag-link-position-42" style="font-size: 11.522012578616pt;" aria-label="theft (263 items)">theft</a>
<a href="https://caymannewsservice.com/tag/traffic-offences/" class="tag-cloud-link tag-link-608 tag-link-position-43" style="font-size: 9.5849056603774pt;" aria-label="traffic offences (158 items)">traffic offences</a>
<a href="https://caymannewsservice.com/tag/violent-crime/" class="tag-cloud-link tag-link-129 tag-link-position-44" style="font-size: 12.22641509434pt;" aria-label="violent crime (317 items)">violent crime</a>
<a href="https://caymannewsservice.com/tag/wayne-panton/" class="tag-cloud-link tag-link-264 tag-link-position-45" style="font-size: 10.377358490566pt;" aria-label="Wayne Panton (196 items)">Wayne Panton</a></div>
</div></div><div id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget"><div class="widget-wrap">
<div
	class="hide-on-button negative"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://caymannewsservice.com/privacy-cookie-policy/" rel="">
		Privacy &amp; Cookie Policy	</a>
</div>
</div></div>			</div>
			<div class="footer-widget2">
				<div id="calendar-2" class="widget widget_calendar"><div class="widget-wrap"><h3 class="widgettitle"><span>CNS Archives by date</span></h3><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>March 2022</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="1" class="pad">&nbsp;</td><td><a href="https://caymannewsservice.com/2022/03/01/" aria-label="Posts published on 1 March 2022">1</a></td><td><a href="https://caymannewsservice.com/2022/03/02/" aria-label="Posts published on 2 March 2022">2</a></td><td><a href="https://caymannewsservice.com/2022/03/03/" aria-label="Posts published on 3 March 2022">3</a></td><td><a href="https://caymannewsservice.com/2022/03/04/" aria-label="Posts published on 4 March 2022">4</a></td><td>5</td><td>6</td>
	</tr>
	<tr>
		<td><a href="https://caymannewsservice.com/2022/03/07/" aria-label="Posts published on 7 March 2022">7</a></td><td><a href="https://caymannewsservice.com/2022/03/08/" aria-label="Posts published on 8 March 2022">8</a></td><td><a href="https://caymannewsservice.com/2022/03/09/" aria-label="Posts published on 9 March 2022">9</a></td><td><a href="https://caymannewsservice.com/2022/03/10/" aria-label="Posts published on 10 March 2022">10</a></td><td><a href="https://caymannewsservice.com/2022/03/11/" aria-label="Posts published on 11 March 2022">11</a></td><td>12</td><td>13</td>
	</tr>
	<tr>
		<td><a href="https://caymannewsservice.com/2022/03/14/" aria-label="Posts published on 14 March 2022">14</a></td><td><a href="https://caymannewsservice.com/2022/03/15/" aria-label="Posts published on 15 March 2022">15</a></td><td><a href="https://caymannewsservice.com/2022/03/16/" aria-label="Posts published on 16 March 2022">16</a></td><td><a href="https://caymannewsservice.com/2022/03/17/" aria-label="Posts published on 17 March 2022">17</a></td><td><a href="https://caymannewsservice.com/2022/03/18/" aria-label="Posts published on 18 March 2022">18</a></td><td>19</td><td>20</td>
	</tr>
	<tr>
		<td><a href="https://caymannewsservice.com/2022/03/21/" aria-label="Posts published on 21 March 2022">21</a></td><td><a href="https://caymannewsservice.com/2022/03/22/" aria-label="Posts published on 22 March 2022">22</a></td><td><a href="https://caymannewsservice.com/2022/03/23/" aria-label="Posts published on 23 March 2022">23</a></td><td id="today"><a href="https://caymannewsservice.com/2022/03/24/" aria-label="Posts published on 24 March 2022">24</a></td><td>25</td><td>26</td><td>27</td>
	</tr>
	<tr>
		<td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="3">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://caymannewsservice.com/2022/02/">&laquo; Feb</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div></div>			</div>
			<div class="footer-widget3">
				<div id="featured-page-2" class="widget featuredpage"><div class="widget-wrap">
							<h3 class="widgettitle"><span><a href="https://caymannewsservice.com/about-cns/">About CNS</a></span></h3>				
			<div class="post clearfix">

					
			
				
								
			</div>
					
		</div></div><div id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-cns-container"><ul id="menu-cns" class="menu"><li id="menu-item-74884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74884"><a href="https://caymannewsservice.com/about-cns/">About CNS</a></li>
<li id="menu-item-35352" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35352"><a title="Cayman News Service Privacy and Cookie Policy" href="https://caymannewsservice.com/privacy-cookie-policy/">Privacy &#038; Cookie Policy</a></li>
<li id="menu-item-35357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35357"><a title="CNS Terms and Conditions" href="https://caymannewsservice.com/cns-terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-35354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35354"><a title="About CNS Viewpoints" href="https://caymannewsservice.com/about-cns-viewpoints/">CNS Viewpoints</a></li>
<li id="menu-item-35356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35356"><a title="CNS Comment Policy" href="https://caymannewsservice.com/cns-comment-policy/">Comment Policy</a></li>
<li id="menu-item-35355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35355"><a href="https://caymannewsservice.com/contact-us/">Contact Us</a></li>
<li id="menu-item-35358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35358"><a href="http://eepurl.com/bHEp">Sign up for CNS Newsletter</a></li>
<li id="menu-item-35359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35359"><a href="https://caymannewsservice.com/rates/">Advertise with CNS</a></li>
</ul></div></div></div>			</div>
			<div class="footer-widget4">
							</div>
		</div>
	</div> <!-- End #footer-widgets div -->
	
	<div id="footer">
		<div class="limit clearfix">
			<p class="footurl"><a href="https://caymannewsservice.com">Cayman News Service</a></p>
						&copy;  2022 Cayman News Service. All rights reserved. <a href="http://www.solostream.com" rel="nofollow">Theme by Solostream</a>.
		</div>
	</div> <!-- End #footer div -->

</div> <!-- End #outerwrap div -->

<div style="display: none;"><div id="boxzilla-box-99049-content"><p><a href="https://caymannewsservice.com/tipbox/" target="_blank" rel="noopener"><img class="aligncenter size-full wp-image-99050" src="https://i0.wp.com/caymannewsservice.com/wp-content/uploads/2022/01/BUY-CUP-OF-COFFEE-v2.png?resize=250%2C250&#038;ssl=1" alt="" width="250" height="250" data-recalc-dims="1" /></a></p>
</div></div>    <!-- LikeBtn.com BEGIN -->
    <script type="text/javascript">var likebtn_wl = 1; (function(d, e, s) {a = d.createElement(e);m = d.getElementsByTagName(e)[0];a.async = 1;a.src = s;m.parentNode.insertBefore(a, m)})(document, 'script', '//w.likebtn.com/js/w/widget.js'); if (typeof(LikeBtn) != "undefined") { LikeBtn.init(); }</script>
    <!-- LikeBtn.com END -->
                 <script type="text/javascript" id="pf_script">
                      var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfEncodeImages = '0';
          var pfShowHiddenContent  = '0';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
        var pfPlatform = 'WordPress';

        (function($){
            $(document).ready(function(){
                if($('.pf-button-content').length === 0){
                    $('style#pf-excerpt-styles').remove();
                }
            });
        })(jQuery);
        </script>
      <script async src='https://cdn.printfriendly.com/printfriendly.js'></script>
            		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea autocomplete="new-password" 
													id="f6c5908192"  name="f6c5908192" 
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													
													placeholder="Write a Comment..."
												></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "adfdcad1dc0f9ae17bdc70ae3d9ab5e8" );document.getElementById("f6c5908192").setAttribute( "id", "comment" );</script>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/caymannewsservice.com\/2022\/03\/driver-badly-hurt-after-light-pole-collision\/":101317};
	</script>
						<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.7/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.7/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=ba2aa80003251440130b63de19cb609d' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=ae8c0bea6a07ab76470a02053fc74216' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='boxzilla-js-extra'>
/* <![CDATA[ */
var boxzilla_options = {"testMode":"","boxes":[{"id":99049,"icon":"&times;","content":"","css":{"background_color":"#eeee22","border_color":"#dd3333","border_width":5,"border_style":"dashed","position":"bottom-left"},"trigger":{"method":"percentage","value":10},"animation":"slide","cookie":{"triggered":0,"dismissed":120},"rehide":false,"position":"bottom-left","screenWidthCondition":null,"closable":true,"post":{"id":99049,"title":"coffee cup","slug":"coffee-cup"}}]};
/* ]]> */
</script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/boxzilla/assets/js/script.min.js?ver=3.2.25' id='boxzilla-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.2/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/caymannewsservice.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/caymannewsservice.com\/wp-admin\/admin-ajax.php","nonce":"7f181bfdf1","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"0","login_url":"https:\/\/caymannewsservice.com\/cnslogin\/?redirect_to=https%3A%2F%2Fcaymannewsservice.com%2F2022%2F03%2Fdriver-badly-hurt-after-light-pole-collision%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.7/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.7/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>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</script>
<script src='https://stats.wp.com/e-202212.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7',blog:'77091667',post:'101317',tz:'-5',srv:'caymannewsservice.com'} ]);
	_stq.push([ 'clickTrackerInit', '77091667', '101317' ]);
</script>

</body>

</html><!-- WP Fastest Cache file was created in 2.1751699447632 seconds, on 24-03-22 12:58:21 -->