<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-GB">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title> How would you grade your MLAs this past term? (Part 2) : Cayman News Service</title>
<link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear321/style.css" type="text/css" media="screen"/>
<link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear321/style-font.css" type="text/css" media="screen"/>
<script type="text/javascript">
var SITE_URL = "https://caymannewsservice.com";
</script>
 
<link rel="stylesheet" href="https://caymannewsservice.com/wp-content/themes/wp-clear321/style-responsive.css" type="text/css" media="screen"/>
<meta name="viewport" content="width=device-width,initial-scale=1"/>
<link rel="pingback" href="https://caymannewsservice.com/xmlrpc.php"/>
 
<meta name="google-site-verification" content="D1kGA0KHCR-7CU-o08fDKcYvl5zvzQJld3jKDhwIYrY"/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Cayman News Service &raquo; Feed" href="https://caymannewsservice.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Cayman News Service &raquo; Comments Feed" href="https://caymannewsservice.com/comments/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/caymannewsservice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=b0f9b0af916f663cfbd0bf1d238105a7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='cld-font-awesome-css' href='https://caymannewsservice.com/wp-content/plugins/comments-like-dislike/css/font-awesome.min.css?ver=1.0.2' type='text/css' media='all'/>
<link rel='stylesheet' id='cld-frontend-css' href='https://caymannewsservice.com/wp-content/plugins/comments-like-dislike/css/cld-frontend.css?ver=1.0.2' type='text/css' media='all'/>
<link rel='stylesheet' id='social-logos-css' href='https://caymannewsservice.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='https://caymannewsservice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all'/>
<script type='text/javascript' src='https://caymannewsservice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cld_js_object = {"admin_ajax_url":"https:\/\/caymannewsservice.com\/wp-admin\/admin-ajax.php","admin_ajax_nonce":"b2f64e6ac1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/comments-like-dislike/js/cld-frontend.js?ver=1.0.2'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear321/js/external.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear321/js/suckerfish.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear321/js/suckerfish-cat.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear321/js/jquery.mobilemenu.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/themes/wp-clear321/js/flexslider.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<link rel='https://api.w.org/' href='https://caymannewsservice.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://caymannewsservice.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://caymannewsservice.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Brac customs officer denies having illegal gun' href='https://caymannewsservice.com/2017/04/brac-customs-officer-denies-having-illegal-gun/'/>
<link rel='next' title='Power outage from George Town to Frank Sound' href='https://caymannewsservice.com/2017/04/power-outage-in-from-george-town-to-frank-sound/'/>
<link rel="canonical" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/"/>
<link rel='shortlink' href='https://caymannewsservice.com/?p=18326'/>
<link rel="alternate" type="application/json+oembed" href="https://caymannewsservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaymannewsservice.com%2F2017%2F04%2Fhow-would-you-grade-your-mlas-this-past-term-part-2%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://caymannewsservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcaymannewsservice.com%2F2017%2F04%2Fhow-would-you-grade-your-mlas-this-past-term-part-2%2F&#038;format=xml"/>
<style></style>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style>
 
<link href="https://caymannewsservice.com/wp-content/themes/wp-clear321/styles/default.css" rel="stylesheet" type="text/css"/>
 
<style type="text/css">body{font-family:Arial,Helvetica,sans-serif;}#topnav{border-bottom:0}#wrap{padding:20px 30px 20px;border-width:2px;border-style:solid;border-color:#2f739c;box-shadow:0px 2px 5px rgba(100,100,100,.3);-moz-box-shadow:0px 2px 5px rgba(100,100,100,.3);-webkit-box-shadow:0px 2px 5px rgba(100,100,100,.3);margin:30px auto}h1,h2,h3,h4,h5,h6,h7,#sitetitle .title{font-family:Calibri,Arial,sans-serif;font-weight:bold;}h1,h2,h3,h4,h5,h6,h7,#sitetitle .title{font-weight:bold;}.post-title a,.post-title a:link,.post-title a:visited{color:#2f739c!important;}#sitetitle,#logo{float:left;width:49%;}#sitetitle .title,#sitetitle .description{float:none;text-indent:-999em;position:absolute;display:none;left:-999em;}#topnav,#topnav ul ul a{font-size:12pt;font-weight:bold;font-family:Calibri,Arial,sans-serif;background:#2f739c;}#topnav ul a,#topnav ul ul a{color:#ffffff;}#topnav ul a:hover,#topnav ul ul a:hover{color:#050505;}#topnav ul a:hover,#topnav ul ul a:hover{background-color:#c0c2c0;}#catnav,#catnav ul ul a{font-size:10pt;font-weight:bold;font-family:Calibri,Arial,sans-serif;}.maincontent,#content{font-size:10pt;}#contentright{font-size:10pt;}a.comment-reply-link,a.comment-reply-link:link,a.comment-reply-link:visited,#commentform input#submit,.archive-tabs a,.archive-tabs a:link,.archive-tabs a:visited,a.more-link,a.more-link:link,a.more-link:visited,p.email-form .subbutton,#searchform #submitbutton{border-color:#f0f0f0;background-color:#f0f0f0;}a.comment-reply-link,a.comment-reply-link:link,a.comment-reply-link:visited,#commentform input#submit,.archive-tabs a,.archive-tabs a:link,.archive-tabs a:visited,a.more-link,a.more-link:link,a.more-link:visited,p.email-form .subbutton,#searchform #submitbutton{color:#9c050f!important;}#footer{font-size:12pt;}</style>
 
<link href="https://caymannewsservice.com/wp-content/themes/wp-clear321/custom.css" rel="stylesheet" type="text/css"/>
 
<script type="text/javascript">
		jQuery(function () {
			jQuery('.nav').mobileMenu({ defaultText: 'Navigate to ...' });
			jQuery('.catnav').mobileMenu({ defaultText: 'Navigate to ... ', className: 'select-menu-catnav' });
		});
	</script>
 
<!--[if lt IE 9]>
		<script type="text/javascript" src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
	<![endif]-->
<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important;}</style>
 
<meta property="og:type" content="article"/>
<meta property="og:title" content="How would you grade your MLAs this past term? (Part 2)"/>
<meta property="og:url" content="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/"/>
<meta property="og:description" content="101 writes: Now that Nomination Day is far behind us, it’s time for the promised Part 2 of grading the other representatives. Spoiler alert: there are no A*s in here."/>
<meta property="article:published_time" content="2017-04-27T15:11:09+00:00"/>
<meta property="article:modified_time" content="2017-04-27T15:13:02+00:00"/>
<meta property="og:site_name" content="Cayman News Service"/>
<meta property="og:image" content="https://caymannewsservice.com/wp-content/uploads/2017/02/Election-vp.png"/>
<meta property="og:image:secure_url" content="https://i1.wp.com/caymannewsservice.com/wp-content/uploads/2017/02/Election-vp.png?ssl=1"/>
<meta property="og:locale" content="en_GB"/>
<meta name="twitter:site" content="@CaymanNews"/>
<meta name="twitter:image" content="https://caymannewsservice.com/wp-content/uploads/2017/02/Election-vp.png?w=1400"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:creator" content="@CaymanNews"/>
<link rel="icon" href="https://caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon-256x256.png" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon-256x256.png"/>
<meta name="msapplication-TileImage" content="https://caymannewsservice.com/wp-content/uploads/2015/03/CNS-logo-512-pix-for-favicon-550312f2v1_site_icon.png"/>
</head>
<body class="post-template-default single single-post postid-18326 single-format-standard c-sw">
<div class="outer-wrap">
<div id="topnav">
<div class="limit">
<ul class="nav clearfix">
<li id="menu-item-1586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1586"><a title="CNS rate sheet" href="http://caymannewsservice.com/rates/">Advertising Rates</a></li>
<li id="menu-item-11748" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11748"><a href="https://caymannewsservice.com/about-cns/">About CNS</a></li>
<li id="menu-item-1549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1549"><a title="Contact CNS staff" href="https://caymannewsservice.com/contact-us/">Contact Us</a></li>
<li id="menu-item-1550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1550"><a title="CNS Comment Policy Basics" href="https://caymannewsservice.com/cns-comment-policy/">Comment Policy</a></li>
<li id="menu-item-5408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5408"><a href="http://eepurl.com/bHEp">Sign up for CNS Newsletter</a></li>
<li class="rss-comments"><a title="Comments RSS Feed" href="https://caymannewsservice.com/comments/feed/">Comments</a></li>
<li class="rss-content"><a title="Posts RSS Feed" href="https://caymannewsservice.com/feed/">Posts</a></li>
</ul>
</div>
</div>
<div id="wrap">
<div id="header">
<div id="head-content" class="clearfix">
<div id="logo">
<a href="https://caymannewsservice.com" title="Cayman News Service"><img src="https://caymannewsservice.com/wp-content/uploads/2014/10/CNS-logo-for-wp-site1.jpg" alt="Cayman News Service"/></a>
</div>
<div class="head-banner468">
<script type="text/javascript">
            var imagesArray590225ae5dc87 = new Array("https://caymannewsservice.com/wp-content/uploads/2014/10/BritCay-home-insurance-Jan-2017.gif", "https://caymannewsservice.com/wp-content/uploads/2014/10/Flow-March-2017.gif", "https://caymannewsservice.com/wp-content/uploads/2014/10/NCB-Cayman.gif", "https://caymannewsservice.com/wp-content/uploads/2014/10/PPM-strong2-450x100.png", "https://caymannewsservice.com/wp-content/uploads/2014/10/PPM-strong2-450x100.png", "https://caymannewsservice.com/wp-content/uploads/2014/10/PPM-strong2-450x100.png");
            var linkArray590225ae5dc87 = new Array("https://cayman.cgigroup.com/en/", "https://discoverflow.ky/valueplans", "http://ncbcayman.com/", "http://www.theprogressives.ky", "http://www.theprogressives.ky", "http://www.theprogressives.ky");
            var altArray590225ae5dc87 = new Array("BritCay", "Flow", "NCB", "PPM", "PPM", "PPM");
            var idArray590225ae5dc87 = new Array("16071", "17569", "16208", "17750", "17750", "17750");
            var indexArray590225ae5dc87 = new Array("0", "1", "2", "3", "4", "5");
            var currentAd590225ae5dc87 = 1;
            var imgCt590225ae5dc87 = 6;
            function cycle590225ae5dc87() {
                if (currentAd590225ae5dc87 == imgCt590225ae5dc87) {
                    currentAd590225ae5dc87 = 0;
                }
                var banner590225ae5dc87 = document.getElementById('adBanner590225ae5dc87');
                var link590225ae5dc87 = document.getElementById('adLink590225ae5dc87');
                banner590225ae5dc87.src = imagesArray590225ae5dc87[currentAd590225ae5dc87];
                banner590225ae5dc87.alt = idArray590225ae5dc87[currentAd590225ae5dc87];
                banner590225ae5dc87.title = altArray590225ae5dc87[currentAd590225ae5dc87];
                jQuery('#adBanner590225ae5dc87').attr("cur_index",indexArray590225ae5dc87[currentAd590225ae5dc87]);
                document.getElementById('adLink590225ae5dc87').href = linkArray590225ae5dc87[currentAd590225ae5dc87];            currentAd590225ae5dc87++;
            }
            window.setInterval("cycle590225ae5dc87()", 6000);
        </script>
<a target="_blank" href="https://cayman.cgigroup.com/en/" class="banner-poster" id="adLink590225ae5dc87" target="_top">
<img title="BritCay" cur_index="0" class="banner-add" advert="19" src="https://caymannewsservice.com/wp-content/uploads/2014/10/BritCay-home-insurance-Jan-2017.gif" alt="16071" id="adBanner590225ae5dc87" border="0">
</a>
</div>
</div>
</div>
<div id="catnav">
<ul class="catnav clearfix">
<li id="menu-item-98" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-98"><a title="Cayman News Service" href="https://caymannewsservice.com">Home</a>
<ul class="sub-menu">
<li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-93"><a href="https://caymannewsservice.com/category/politics/">Politics</a></li>
<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="https://caymannewsservice.com/category/crime/">Crime</a></li>
<li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://caymannewsservice.com/category/local-news/">Local News</a></li>
<li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="https://caymannewsservice.com/category/health/">Health</a></li>
<li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://caymannewsservice.com/category/science-nature/">Science &#038; Nature</a></li>
<li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://caymannewsservice.com/category/world-news/">World News</a></li>
<li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-96"><a title="Commentary" href="https://caymannewsservice.com/category/viewpoint/">Viewpoint</a></li>
<li id="menu-item-11749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11749"><a href="https://caymannewsservice.com/about-cns-viewpoints/">About CNS Viewpoints</a></li>
</ul>
</li>
<li id="menu-item-16179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16179"><a href="http://caymannewsservice.com/elections2017">Election Section</a></li>
<li id="menu-item-99" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-99"><a title="CNS Business" href="http://cnsbusiness.com/">Business News</a>
<ul class="sub-menu">
<li id="menu-item-13208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13208"><a href="https://cnsbusiness.com">Latest Business News</a></li>
<li id="menu-item-13209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13209"><a href="https://cnsbusiness.com/category/goldenspoons/">Golden Spoons Restaurant Reviews</a></li>
</ul>
</li>
<li id="menu-item-1809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1809"><a title="Cayman Islands Sports and community News" href="https://cnslocallife.com/">Local Life</a>
<ul class="sub-menu">
<li id="menu-item-13210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13210"><a href="https://cnslocallife.com/category/ask-auntie/">Ask Auntie</a></li>
<li id="menu-item-13211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13211"><a href="https://cnslocallife.com/">Community News</a></li>
<li id="menu-item-1880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1880"><a title="Cayman Islands Sports" href="https://caymannewsservice.com/local_news/category/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-13212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13212"><a title="Documents and Information Portal" href="http://cnslibrary.com">CNS Library</a></li>
<li id="menu-item-100" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100"><a title="Free Classifieds from the Cayman Islands" href="https://freecayads.com">FreeCayAds</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163"><a title="Cayman Islands Notice Board" href="http://freecayads.com/?cat=9">Notice Board</a></li>
<li class="search"><form id="searchform" method="get" action="https://caymannewsservice.com/"><input type="text" value="Enter Search Terms" onfocus="if (this.value == 'Enter Search Terms') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Enter Search Terms';}" size="18" maxlength="50" name="s" id="searchfield"/><input type="submit" value="search" id="submitbutton"/></form>
</li>
</ul>
</div>
<div class="banner728-container clearfix">
<div class="banner728 left">
<script type="text/javascript">
            var imagesArray590225ae663fb = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/CNB-bank-of-the-year-jan-2017-v2.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/RBC-Mobile-Banking.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/Dennie-Warren-2.jpg");
            var linkArray590225ae663fb = new Array("https://www.caymannational.com/", "https://www.rbcroyalbank.com/caribbean/mobile/index.html", "http://www.votewarren.ky/");
            var altArray590225ae663fb = new Array("CNB", "RBC", "Dennie Warren");
            var idArray590225ae663fb = new Array("16228", "15681", "18263");
            var indexArray590225ae663fb = new Array("0", "1", "2");
            var currentAd590225ae663fb = 1;
            var imgCt590225ae663fb = 3;
            function cycle590225ae663fb() {
                if (currentAd590225ae663fb == imgCt590225ae663fb) {
                    currentAd590225ae663fb = 0;
                }
                var banner590225ae663fb = document.getElementById('adBanner590225ae663fb');
                var link590225ae663fb = document.getElementById('adLink590225ae663fb');
                banner590225ae663fb.src = imagesArray590225ae663fb[currentAd590225ae663fb];
                banner590225ae663fb.alt = idArray590225ae663fb[currentAd590225ae663fb];
                banner590225ae663fb.title = altArray590225ae663fb[currentAd590225ae663fb];
                jQuery('#adBanner590225ae663fb').attr("cur_index",indexArray590225ae663fb[currentAd590225ae663fb]);
                document.getElementById('adLink590225ae663fb').href = linkArray590225ae663fb[currentAd590225ae663fb];            currentAd590225ae663fb++;
            }
            window.setInterval("cycle590225ae663fb()", 10000);
        </script>
<a target="_blank" href="https://www.caymannational.com/" class="banner-poster" id="adLink590225ae663fb" target="_top">
<img title="CNB" cur_index="0" class="banner-add" advert="33" src="https://caymannewsservice.com/wp-content/uploads/2015/01/CNB-bank-of-the-year-jan-2017-v2.gif" alt="16228" id="adBanner590225ae663fb" border="0">
</a>
</div>
<div class="banner220">
<a href='http://kennethbryan.ky'><img src='http://kennethbryan.ky/images/togetherwecan.gif' alt='banner ad'/></a> </div>
</div>
<div id="page" class="clearfix">
<div class="page-border clearfix">
<div id="contentleft" class="clearfix">
<div id="content" class="clearfix">
<div class="banner468">
<script type="text/javascript">
            var imagesArray590225ae69b1b = new Array("https://caymannewsservice.com/wp-content/uploads/2014/11/VamptSales-Jan2017.png", "https://caymannewsservice.com/wp-content/uploads/2014/11/Home-Gas-Free-gas-tank-replacement.png", "https://caymannewsservice.com/wp-content/uploads/2014/11/Vampt-Service-Batteries.jpg");
            var linkArray590225ae69b1b = new Array("http://www.vamptmotors.com/", "http://www.homegas.net", "http://www.vamptmotors.com/");
            var altArray590225ae69b1b = new Array("Vampt Motors", "Home Gas", "Vampt Service");
            var idArray590225ae69b1b = new Array("15550", "17137", "16440");
            var indexArray590225ae69b1b = new Array("0", "1", "2");
            var currentAd590225ae69b1b = 1;
            var imgCt590225ae69b1b = 3;
            function cycle590225ae69b1b() {
                if (currentAd590225ae69b1b == imgCt590225ae69b1b) {
                    currentAd590225ae69b1b = 0;
                }
                var banner590225ae69b1b = document.getElementById('adBanner590225ae69b1b');
                var link590225ae69b1b = document.getElementById('adLink590225ae69b1b');
                banner590225ae69b1b.src = imagesArray590225ae69b1b[currentAd590225ae69b1b];
                banner590225ae69b1b.alt = idArray590225ae69b1b[currentAd590225ae69b1b];
                banner590225ae69b1b.title = altArray590225ae69b1b[currentAd590225ae69b1b];
                jQuery('#adBanner590225ae69b1b').attr("cur_index",indexArray590225ae69b1b[currentAd590225ae69b1b]);
                document.getElementById('adLink590225ae69b1b').href = linkArray590225ae69b1b[currentAd590225ae69b1b];            currentAd590225ae69b1b++;
            }
            window.setInterval("cycle590225ae69b1b()", 10000);
        </script>
<a target="_blank" href="http://www.vamptmotors.com/" class="banner-poster" id="adLink590225ae69b1b" target="_top">
<img title="Vampt Motors" cur_index="0" class="banner-add" advert="26" src="https://caymannewsservice.com/wp-content/uploads/2014/11/VamptSales-Jan2017.png" alt="15550" id="adBanner590225ae69b1b" border="0">
</a>
</div>
<div class="post" id="post-main-18326">
<div class="entry">
<h1 class="post-title single"><a href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/" rel="bookmark" title="Permanent Link to How would you grade your MLAs this past term? (Part 2)">How would you grade your MLAs this past term? (Part 2)</a></h1>
<div class="meta single">
<span class="meta-author">
<a href="https://caymannewsservice.com/author/cayman-news/" title="Posts by Cayman News" rel="author">Cayman News</a> |
</span>
<span class="meta-date">
27/04/2017 </span>
</div>
<p><strong><a href="https://caymannewsservice.com/wp-content/uploads/2017/02/Election-vp.png"><img class="alignleft size-full wp-image-16490" src="https://caymannewsservice.com/wp-content/uploads/2017/02/Election-vp.png" alt="Cayman News Service" width="150" height="150"/></a>101 writes:</strong> Now that Nomination Day is far behind us, it’s time for the promised Part 2 of grading the other representatives. Spoiler alert: there are no A*s in here.<span id="more-18326"></span></p>
<p><a href="http://caymannewsservice.com/elections2017" target="_blank" rel="noopener noreferrer">Read more and comment on the CNS Election Section</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-18326" class="share-facebook sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-18326" class="share-twitter sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-18326" class="share-linkedin sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-18326" class="share-google-plus-1 sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-18326" class="share-pinterest sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-18326" class="share-skype sd-button share-icon no-text" href="https://caymannewsservice.com/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-77091667-18326-590225ae6da05' data-src='//widgets.wp.com/likes/#blog_id=77091667&amp;post_id=18326&amp;origin=caymannewsservice.com&amp;obj_id=77091667-18326-590225ae6da05' data-name='like-post-frame-77091667-18326-590225ae6da05'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div style="clear:both;"></div>
<p class="tags"><strong>Tags: </strong> <a href="https://caymannewsservice.com/tag/101/" rel="tag">101</a>, <a href="https://caymannewsservice.com/tag/cns-election-section/" rel="tag">CNS Election Section</a></p> <p class="cats"><strong>Category</strong>: <a href="https://caymannewsservice.com/category/politics/elections/2017-general-elections/" rel="category tag">2017 General Elections</a>, <a href="https://caymannewsservice.com/category/politics/elections/" rel="category tag">Elections</a>, <a href="https://caymannewsservice.com/category/politics/" rel="category tag">Politics</a>, <a href="https://caymannewsservice.com/category/viewpoint/" rel="category tag">Viewpoint</a></p>
</div>
</div>
 
<div id="comments">
<div class="allcomments">
 
<p class="nocomments">Comments are closed.</p>
</div>
</div>
<div class="navigation clearfix">
<div class="alignleft single">
&laquo; <a href="https://caymannewsservice.com/2017/04/brac-customs-officer-denies-having-illegal-gun/" rel="prev">Brac customs officer denies having illegal gun</a> </div>
<div class="alignright single">
<a href="https://caymannewsservice.com/2017/04/power-outage-in-from-george-town-to-frank-sound/" rel="next">Power outage from George Town to Frank Sound</a> &raquo; </div>
</div>
</div>  
</div>  
<div id="contentright">
<div id="sidebar" class="clearfix">
<div id="advert-banner-widget-2" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae70112 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Logic-March-2017.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/BDO-April.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/24-hour-truck-gif.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/Alva-Suckoo.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/Tara-Rivers.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/Jonathan-Piercy.gif");
            var linkArray590225ae70112 = new Array("https://www.logic.ky/residential/tv/fiber-tv/logic-tv/logictv-bundles", "http://www.bdo.ky/en-gb/services/tax/personal-tax-services", "http://www.industrialservices.ky/", "http://suckoo2017.ky/", "http://www.tararivers.ky/", "https://www.jonathanpiercy.org/");
            var altArray590225ae70112 = new Array("Logic", "BDO", "ISE", "Alva Suckoo", "Tara Rivers", "Jonathan Piercy");
            var idArray590225ae70112 = new Array("17385", "17795", "18261", "17692", "17892", "18192");
            var indexArray590225ae70112 = new Array("0", "1", "2", "3", "4", "5");
            var currentAd590225ae70112 = 1;
            var imgCt590225ae70112 = 6;
            function cycle590225ae70112() {
                if (currentAd590225ae70112 == imgCt590225ae70112) {
                    currentAd590225ae70112 = 0;
                }
                var banner590225ae70112 = document.getElementById('adBanner590225ae70112');
                var link590225ae70112 = document.getElementById('adLink590225ae70112');
                banner590225ae70112.src = imagesArray590225ae70112[currentAd590225ae70112];
                banner590225ae70112.alt = idArray590225ae70112[currentAd590225ae70112];
                banner590225ae70112.title = altArray590225ae70112[currentAd590225ae70112];
                jQuery('#adBanner590225ae70112').attr("cur_index",indexArray590225ae70112[currentAd590225ae70112]);
                document.getElementById('adLink590225ae70112').href = linkArray590225ae70112[currentAd590225ae70112];            currentAd590225ae70112++;
            }
            window.setInterval("cycle590225ae70112()", 6000);
        </script>
<a target="_blank" href="https://www.logic.ky/residential/tv/fiber-tv/logic-tv/logictv-bundles" class="banner-poster" id="adLink590225ae70112" target="_top">
<img title="Logic" cur_index="0" class="banner-add" advert="37" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Logic-March-2017.gif" alt="17385" id="adBanner590225ae70112" border="0">
</a>
</div></div><div id="advert-banner-widget-3" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae7430d = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Silver-Thatch-Pensions-CHICKS.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/Cayman-Travel-320x180.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/wok-n-roll-feb-2017-6-secs.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/Travel-Pros-2017.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/ESO-April-2017.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/Local-scholarship-opportunities-March-2017.gif");
            var linkArray590225ae7430d = new Array("http://silverthatch.org.ky/", "http://www.caymantravel.ky/", "http://www.woknroll.ky/", "https://www.facebook.com/TravelProsGCM/", "https://freecayads.com/2017/02/28/the-spring-2017-labour-force-survey-starts-on-sunday-5th-march/", "http://www.education.gov.ky/portal/page/portal/mehhome/education/scholarships");
            var altArray590225ae7430d = new Array("Silver Thatch Pensions", "Cayman Travel", "WoknRoll", "Travel Pros", "ESO", "");
            var idArray590225ae7430d = new Array("18040", "247", "16341", "15668", "17844", "17754");
            var indexArray590225ae7430d = new Array("0", "1", "2", "3", "4", "5");
            var currentAd590225ae7430d = 1;
            var imgCt590225ae7430d = 6;
            function cycle590225ae7430d() {
                if (currentAd590225ae7430d == imgCt590225ae7430d) {
                    currentAd590225ae7430d = 0;
                }
                var banner590225ae7430d = document.getElementById('adBanner590225ae7430d');
                var link590225ae7430d = document.getElementById('adLink590225ae7430d');
                banner590225ae7430d.src = imagesArray590225ae7430d[currentAd590225ae7430d];
                banner590225ae7430d.alt = idArray590225ae7430d[currentAd590225ae7430d];
                banner590225ae7430d.title = altArray590225ae7430d[currentAd590225ae7430d];
                jQuery('#adBanner590225ae7430d').attr("cur_index",indexArray590225ae7430d[currentAd590225ae7430d]);
                document.getElementById('adLink590225ae7430d').href = linkArray590225ae7430d[currentAd590225ae7430d];            currentAd590225ae7430d++;
            }
            window.setInterval("cycle590225ae7430d()", 6000);
        </script>
<a target="_blank" href="http://silverthatch.org.ky/" class="banner-poster" id="adLink590225ae7430d" target="_top">
<img title="Silver Thatch Pensions" cur_index="0" class="banner-add" advert="39" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Silver-Thatch-Pensions-CHICKS.jpg" alt="18040" id="adBanner590225ae7430d" border="0">
</a>
</div></div><div id="advert-banner-widget-4" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae783a0 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Seaboard-Cayman-320x75.gif");
            var linkArray590225ae783a0 = new Array("https://cnsbusiness.com/wp-content/uploads/2016/01/Seaboard-Flyers.pdf");
            var altArray590225ae783a0 = new Array("Seaboard Marine");
            var idArray590225ae783a0 = new Array("6991");
            var indexArray590225ae783a0 = new Array("0");
            var currentAd590225ae783a0 = 1;
            var imgCt590225ae783a0 = 1;
            function cycle590225ae783a0() {
                if (currentAd590225ae783a0 == imgCt590225ae783a0) {
                    currentAd590225ae783a0 = 0;
                }
                var banner590225ae783a0 = document.getElementById('adBanner590225ae783a0');
                var link590225ae783a0 = document.getElementById('adLink590225ae783a0');
                banner590225ae783a0.src = imagesArray590225ae783a0[currentAd590225ae783a0];
                banner590225ae783a0.alt = idArray590225ae783a0[currentAd590225ae783a0];
                banner590225ae783a0.title = altArray590225ae783a0[currentAd590225ae783a0];
                jQuery('#adBanner590225ae783a0').attr("cur_index",indexArray590225ae783a0[currentAd590225ae783a0]);
                document.getElementById('adLink590225ae783a0').href = linkArray590225ae783a0[currentAd590225ae783a0];            currentAd590225ae783a0++;
            }
            window.setInterval("cycle590225ae783a0()", 15000);
        </script>
<a target="_blank" href="https://cnsbusiness.com/wp-content/uploads/2016/01/Seaboard-Flyers.pdf" class="banner-poster" id="adLink590225ae783a0" target="_top">
<img title="Seaboard Marine" cur_index="0" class="banner-add" advert="46" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Seaboard-Cayman-320x75.gif" alt="6991" id="adBanner590225ae783a0" border="0">
</a>
</div></div><div id="advert-banner-widget-5" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae79cd5 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/miniwarehouse2-320x180.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/CEC-impact-conference.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/CEC-impact-conference.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/Red-Bay-meeting-PPM.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/Red-Bay-meeting-PPM.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/Dennie-Warren.jpg");
            var linkArray590225ae79cd5 = new Array("http://www.miniwarehouse2.com/", "http://events.imanetwork.org/cayman-impact17/", "http://events.imanetwork.org/cayman-impact17/", "http://www.theprogressives.ky", "http://www.theprogressives.ky", "http://www.votewarren.ky/");
            var altArray590225ae79cd5 = new Array("MiniWarehouse2", "Impact 17", "Impact 17", "PPM", "PPM", "Dennie Warren");
            var idArray590225ae79cd5 = new Array("62", "17893", "17893", "18336", "18336", "18262");
            var indexArray590225ae79cd5 = new Array("0", "1", "2", "3", "4", "5");
            var currentAd590225ae79cd5 = 1;
            var imgCt590225ae79cd5 = 6;
            function cycle590225ae79cd5() {
                if (currentAd590225ae79cd5 == imgCt590225ae79cd5) {
                    currentAd590225ae79cd5 = 0;
                }
                var banner590225ae79cd5 = document.getElementById('adBanner590225ae79cd5');
                var link590225ae79cd5 = document.getElementById('adLink590225ae79cd5');
                banner590225ae79cd5.src = imagesArray590225ae79cd5[currentAd590225ae79cd5];
                banner590225ae79cd5.alt = idArray590225ae79cd5[currentAd590225ae79cd5];
                banner590225ae79cd5.title = altArray590225ae79cd5[currentAd590225ae79cd5];
                jQuery('#adBanner590225ae79cd5').attr("cur_index",indexArray590225ae79cd5[currentAd590225ae79cd5]);
                document.getElementById('adLink590225ae79cd5').href = linkArray590225ae79cd5[currentAd590225ae79cd5];            currentAd590225ae79cd5++;
            }
            window.setInterval("cycle590225ae79cd5()", 6000);
        </script>
<a target="_blank" href="http://www.miniwarehouse2.com/" class="banner-poster" id="adLink590225ae79cd5" target="_top">
<img title="MiniWarehouse2" cur_index="0" class="banner-add" advert="48" src="https://caymannewsservice.com/wp-content/uploads/2015/01/miniwarehouse2-320x180.png" alt="62" id="adBanner590225ae79cd5" border="0">
</a>
</div></div><div id="advert-banner-widget-21" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae7cdb8 = new Array("https://caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png");
            var linkArray590225ae7cdb8 = new Array("https://report.iwf.org.uk/ky");
            var altArray590225ae7cdb8 = new Array("IWF");
            var idArray590225ae7cdb8 = new Array("9778");
            var indexArray590225ae7cdb8 = new Array("0");
            var currentAd590225ae7cdb8 = 1;
            var imgCt590225ae7cdb8 = 1;
            function cycle590225ae7cdb8() {
                if (currentAd590225ae7cdb8 == imgCt590225ae7cdb8) {
                    currentAd590225ae7cdb8 = 0;
                }
                var banner590225ae7cdb8 = document.getElementById('adBanner590225ae7cdb8');
                var link590225ae7cdb8 = document.getElementById('adLink590225ae7cdb8');
                banner590225ae7cdb8.src = imagesArray590225ae7cdb8[currentAd590225ae7cdb8];
                banner590225ae7cdb8.alt = idArray590225ae7cdb8[currentAd590225ae7cdb8];
                banner590225ae7cdb8.title = altArray590225ae7cdb8[currentAd590225ae7cdb8];
                jQuery('#adBanner590225ae7cdb8').attr("cur_index",indexArray590225ae7cdb8[currentAd590225ae7cdb8]);
                document.getElementById('adLink590225ae7cdb8').href = linkArray590225ae7cdb8[currentAd590225ae7cdb8];            currentAd590225ae7cdb8++;
            }
            window.setInterval("cycle590225ae7cdb8()", 3000);
        </script>
<a target="_blank" href="https://report.iwf.org.uk/ky" class="banner-poster" id="adLink590225ae7cdb8" target="_top">
<img title="IWF" cur_index="0" class="banner-add" advert="9777" src="https://caymannewsservice.com/wp-content/uploads/2016/05/IWF-child-pornography.png" alt="9778" id="adBanner590225ae7cdb8" border="0">
</a>
</div></div><div id="advert-banner-widget-18" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae7e52c = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Cannon-Place-4-sec.gif");
            var linkArray590225ae7e52c = new Array("http://www.cannonplace.ky/");
            var altArray590225ae7e52c = new Array("Cannon Place");
            var idArray590225ae7e52c = new Array("17031");
            var indexArray590225ae7e52c = new Array("0");
            var currentAd590225ae7e52c = 1;
            var imgCt590225ae7e52c = 1;
            function cycle590225ae7e52c() {
                if (currentAd590225ae7e52c == imgCt590225ae7e52c) {
                    currentAd590225ae7e52c = 0;
                }
                var banner590225ae7e52c = document.getElementById('adBanner590225ae7e52c');
                var link590225ae7e52c = document.getElementById('adLink590225ae7e52c');
                banner590225ae7e52c.src = imagesArray590225ae7e52c[currentAd590225ae7e52c];
                banner590225ae7e52c.alt = idArray590225ae7e52c[currentAd590225ae7e52c];
                banner590225ae7e52c.title = altArray590225ae7e52c[currentAd590225ae7e52c];
                jQuery('#adBanner590225ae7e52c').attr("cur_index",indexArray590225ae7e52c[currentAd590225ae7e52c]);
                document.getElementById('adLink590225ae7e52c').href = linkArray590225ae7e52c[currentAd590225ae7e52c];            currentAd590225ae7e52c++;
            }
            window.setInterval("cycle590225ae7e52c()", 12000);
        </script>
<a target="_blank" href="http://www.cannonplace.ky/" class="banner-poster" id="adLink590225ae7e52c" target="_top">
<img title="Cannon Place" cur_index="0" class="banner-add" advert="64" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Cannon-Place-4-sec.gif" alt="17031" id="adBanner590225ae7e52c" border="0">
</a>
</div></div><div id="advert-banner-widget-19" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae7fd51 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/p1.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/p2-white-background.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/p3-with-shell-italics-white-background.png");
            var linkArray590225ae7fd51 = new Array("http://www.sandonfeat.com/", "http://www.sandonfeat.com/", "http://www.sandonfeat.com/");
            var altArray590225ae7fd51 = new Array("Sandon Feat", "Sandon Feat", "Sandon Feat");
            var idArray590225ae7fd51 = new Array("12868", "12869", "12870");
            var indexArray590225ae7fd51 = new Array("0", "1", "2");
            var currentAd590225ae7fd51 = 1;
            var imgCt590225ae7fd51 = 3;
            function cycle590225ae7fd51() {
                if (currentAd590225ae7fd51 == imgCt590225ae7fd51) {
                    currentAd590225ae7fd51 = 0;
                }
                var banner590225ae7fd51 = document.getElementById('adBanner590225ae7fd51');
                var link590225ae7fd51 = document.getElementById('adLink590225ae7fd51');
                banner590225ae7fd51.src = imagesArray590225ae7fd51[currentAd590225ae7fd51];
                banner590225ae7fd51.alt = idArray590225ae7fd51[currentAd590225ae7fd51];
                banner590225ae7fd51.title = altArray590225ae7fd51[currentAd590225ae7fd51];
                jQuery('#adBanner590225ae7fd51').attr("cur_index",indexArray590225ae7fd51[currentAd590225ae7fd51]);
                document.getElementById('adLink590225ae7fd51').href = linkArray590225ae7fd51[currentAd590225ae7fd51];            currentAd590225ae7fd51++;
            }
            window.setInterval("cycle590225ae7fd51()", 5000);
        </script>
<a target="_blank" href="http://www.sandonfeat.com/" class="banner-poster" id="adLink590225ae7fd51" target="_top">
<img title="Sandon Feat" cur_index="0" class="banner-add" advert="69" src="https://caymannewsservice.com/wp-content/uploads/2015/01/p1.png" alt="12868" id="adBanner590225ae7fd51" border="0">
</a>
</div></div><div id="advert-banner-widget-9" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae828ef = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/STICKS-STONES-2015.png", "https://caymannewsservice.com/wp-content/uploads/2015/01/STICKS-STONES-2015-page2.png", "https://caymannewsservice.com/wp-content/uploads/2015/11/sofa-v3.png");
            var linkArray590225ae828ef = new Array("http://sticksandstones.ky/", "http://sticksandstones.ky/", "http://sticksandstones.ky/");
            var altArray590225ae828ef = new Array("Sticks & Stones1", "Sticks & Stones2", "Sticks & Stones3");
            var idArray590225ae828ef = new Array("223", "225", "5961");
            var indexArray590225ae828ef = new Array("0", "1", "2");
            var currentAd590225ae828ef = 1;
            var imgCt590225ae828ef = 3;
            function cycle590225ae828ef() {
                if (currentAd590225ae828ef == imgCt590225ae828ef) {
                    currentAd590225ae828ef = 0;
                }
                var banner590225ae828ef = document.getElementById('adBanner590225ae828ef');
                var link590225ae828ef = document.getElementById('adLink590225ae828ef');
                banner590225ae828ef.src = imagesArray590225ae828ef[currentAd590225ae828ef];
                banner590225ae828ef.alt = idArray590225ae828ef[currentAd590225ae828ef];
                banner590225ae828ef.title = altArray590225ae828ef[currentAd590225ae828ef];
                jQuery('#adBanner590225ae828ef').attr("cur_index",indexArray590225ae828ef[currentAd590225ae828ef]);
                document.getElementById('adLink590225ae828ef').href = linkArray590225ae828ef[currentAd590225ae828ef];            currentAd590225ae828ef++;
            }
            window.setInterval("cycle590225ae828ef()", 5000);
        </script>
<a target="_blank" href="http://sticksandstones.ky/" class="banner-poster" id="adLink590225ae828ef" target="_top">
<img title="Sticks & Stones1" cur_index="0" class="banner-add" advert="71" src="https://caymannewsservice.com/wp-content/uploads/2015/01/STICKS-STONES-2015.png" alt="223" id="adBanner590225ae828ef" border="0">
</a>
</div></div><div id="advert-banner-widget-30" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae85288 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Footloose.jpg");
            var linkArray590225ae85288 = new Array("https://caymandramasociety.wildapricot.org/");
            var altArray590225ae85288 = new Array("CDS");
            var idArray590225ae85288 = new Array("18041");
            var indexArray590225ae85288 = new Array("0");
            var currentAd590225ae85288 = 1;
            var imgCt590225ae85288 = 1;
            function cycle590225ae85288() {
                if (currentAd590225ae85288 == imgCt590225ae85288) {
                    currentAd590225ae85288 = 0;
                }
                var banner590225ae85288 = document.getElementById('adBanner590225ae85288');
                var link590225ae85288 = document.getElementById('adLink590225ae85288');
                banner590225ae85288.src = imagesArray590225ae85288[currentAd590225ae85288];
                banner590225ae85288.alt = idArray590225ae85288[currentAd590225ae85288];
                banner590225ae85288.title = altArray590225ae85288[currentAd590225ae85288];
                jQuery('#adBanner590225ae85288').attr("cur_index",indexArray590225ae85288[currentAd590225ae85288]);
                document.getElementById('adLink590225ae85288').href = linkArray590225ae85288[currentAd590225ae85288];            currentAd590225ae85288++;
            }
            window.setInterval("cycle590225ae85288()", 3000);
        </script>
<a target="_blank" href="https://caymandramasociety.wildapricot.org/" class="banner-poster" id="adLink590225ae85288" target="_top">
<img title="CDS" cur_index="0" class="banner-add" advert="65" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Footloose.jpg" alt="18041" id="adBanner590225ae85288" border="0">
</a>
</div></div><div id="advert-banner-widget-6" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae869d3 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/weather.png");
            var linkArray590225ae869d3 = new Array("http://www.weather.gov.ky/");
            var altArray590225ae869d3 = new Array("Weather");
            var idArray590225ae869d3 = new Array("63");
            var indexArray590225ae869d3 = new Array("0");
            var currentAd590225ae869d3 = 1;
            var imgCt590225ae869d3 = 1;
            function cycle590225ae869d3() {
                if (currentAd590225ae869d3 == imgCt590225ae869d3) {
                    currentAd590225ae869d3 = 0;
                }
                var banner590225ae869d3 = document.getElementById('adBanner590225ae869d3');
                var link590225ae869d3 = document.getElementById('adLink590225ae869d3');
                banner590225ae869d3.src = imagesArray590225ae869d3[currentAd590225ae869d3];
                banner590225ae869d3.alt = idArray590225ae869d3[currentAd590225ae869d3];
                banner590225ae869d3.title = altArray590225ae869d3[currentAd590225ae869d3];
                jQuery('#adBanner590225ae869d3').attr("cur_index",indexArray590225ae869d3[currentAd590225ae869d3]);
                document.getElementById('adLink590225ae869d3').href = linkArray590225ae869d3[currentAd590225ae869d3];            currentAd590225ae869d3++;
            }
            window.setInterval("cycle590225ae869d3()", 3000);
        </script>
<a target="_blank" href="http://www.weather.gov.ky/" class="banner-poster" id="adLink590225ae869d3" target="_top">
<img title="Weather" cur_index="0" class="banner-add" advert="50" src="https://caymannewsservice.com/wp-content/uploads/2015/01/weather.png" alt="63" id="adBanner590225ae869d3" border="0">
</a>
</div></div> </div>
<div id="sidebar-bottom" class="clearfix">
<div id="sidebar-bottom-left">
<div id="advert-banner-widget-10" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae88618 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/Advance-Chevrolet-rental-Jan17.jpg", "https://caymannewsservice.com/wp-content/uploads/2015/01/Advance-Chevrolet-Feb17.jpg");
            var linkArray590225ae88618 = new Array("http://advancecarrentals.com/reservations/", "https://www.facebook.com/advancechevrolet/");
            var altArray590225ae88618 = new Array("Advance Rentals", "Advance");
            var idArray590225ae88618 = new Array("15746", "16502");
            var indexArray590225ae88618 = new Array("0", "1");
            var currentAd590225ae88618 = 1;
            var imgCt590225ae88618 = 2;
            function cycle590225ae88618() {
                if (currentAd590225ae88618 == imgCt590225ae88618) {
                    currentAd590225ae88618 = 0;
                }
                var banner590225ae88618 = document.getElementById('adBanner590225ae88618');
                var link590225ae88618 = document.getElementById('adLink590225ae88618');
                banner590225ae88618.src = imagesArray590225ae88618[currentAd590225ae88618];
                banner590225ae88618.alt = idArray590225ae88618[currentAd590225ae88618];
                banner590225ae88618.title = altArray590225ae88618[currentAd590225ae88618];
                jQuery('#adBanner590225ae88618').attr("cur_index",indexArray590225ae88618[currentAd590225ae88618]);
                document.getElementById('adLink590225ae88618').href = linkArray590225ae88618[currentAd590225ae88618];            currentAd590225ae88618++;
            }
            window.setInterval("cycle590225ae88618()", 6000);
        </script>
<a target="_blank" href="http://advancecarrentals.com/reservations/" class="banner-poster" id="adLink590225ae88618" target="_top">
<img title="Advance Rentals" cur_index="0" class="banner-add" advert="74" src="https://caymannewsservice.com/wp-content/uploads/2015/01/Advance-Chevrolet-rental-Jan17.jpg" alt="15746" id="adBanner590225ae88618" border="0">
</a>
</div></div><div id="advert-banner-widget-13" class="widget banner300"><div class="widget-wrap"></div></div><div id="advert-banner-widget-14" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae8bda2 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/01/LenLayman.gif", "https://caymannewsservice.com/wp-content/uploads/2015/01/Len-man-up.gif");
            var linkArray590225ae8bda2 = new Array("http://www.regalrealtycayman.com/", "http://www.regalrealtycayman.com/");
            var altArray590225ae8bda2 = new Array("Len Layman", "Man Up");
            var idArray590225ae8bda2 = new Array("78", "79");
            var indexArray590225ae8bda2 = new Array("0", "1");
            var currentAd590225ae8bda2 = 1;
            var imgCt590225ae8bda2 = 2;
            function cycle590225ae8bda2() {
                if (currentAd590225ae8bda2 == imgCt590225ae8bda2) {
                    currentAd590225ae8bda2 = 0;
                }
                var banner590225ae8bda2 = document.getElementById('adBanner590225ae8bda2');
                var link590225ae8bda2 = document.getElementById('adLink590225ae8bda2');
                banner590225ae8bda2.src = imagesArray590225ae8bda2[currentAd590225ae8bda2];
                banner590225ae8bda2.alt = idArray590225ae8bda2[currentAd590225ae8bda2];
                banner590225ae8bda2.title = altArray590225ae8bda2[currentAd590225ae8bda2];
                jQuery('#adBanner590225ae8bda2').attr("cur_index",indexArray590225ae8bda2[currentAd590225ae8bda2]);
                document.getElementById('adLink590225ae8bda2').href = linkArray590225ae8bda2[currentAd590225ae8bda2];            currentAd590225ae8bda2++;
            }
            window.setInterval("cycle590225ae8bda2()", 6000);
        </script>
<a target="_blank" href="http://www.regalrealtycayman.com/" class="banner-poster" id="adLink590225ae8bda2" target="_top">
<img title="Len Layman" cur_index="0" class="banner-add" advert="215" src="https://caymannewsservice.com/wp-content/uploads/2015/01/LenLayman.gif" alt="78" id="adBanner590225ae8bda2" border="0">
</a>
</div></div><div id="advert-banner-widget-15" class="widget banner300"><div class="widget-wrap"> <script type="text/javascript">
            var imagesArray590225ae8df10 = new Array("https://caymannewsservice.com/wp-content/uploads/2015/04/CARE_Banner_ad.gif");
            var linkArray590225ae8df10 = new Array("http://caymancare.ky/");
            var altArray590225ae8df10 = new Array("CARE");
            var idArray590225ae8df10 = new Array("4657");
            var indexArray590225ae8df10 = new Array("0");
            var currentAd590225ae8df10 = 1;
            var imgCt590225ae8df10 = 1;
            function cycle590225ae8df10() {
                if (currentAd590225ae8df10 == imgCt590225ae8df10) {
                    currentAd590225ae8df10 = 0;
                }
                var banner590225ae8df10 = document.getElementById('adBanner590225ae8df10');
                var link590225ae8df10 = document.getElementById('adLink590225ae8df10');
                banner590225ae8df10.src = imagesArray590225ae8df10[currentAd590225ae8df10];
                banner590225ae8df10.alt = idArray590225ae8df10[currentAd590225ae8df10];
                banner590225ae8df10.title = altArray590225ae8df10[currentAd590225ae8df10];
                jQuery('#adBanner590225ae8df10').attr("cur_index",indexArray590225ae8df10[currentAd590225ae8df10]);
                document.getElementById('adLink590225ae8df10').href = linkArray590225ae8df10[currentAd590225ae8df10];            currentAd590225ae8df10++;
            }
            window.setInterval("cycle590225ae8df10()", 10000);
        </script>
<a target="_blank" href="http://caymancare.ky/" class="banner-poster" id="adLink590225ae8df10" target="_top">
<img title="CARE" cur_index="0" class="banner-add" advert="2224" src="https://caymannewsservice.com/wp-content/uploads/2015/04/CARE_Banner_ad.gif" alt="4657" id="adBanner590225ae8df10" border="0">
</a>
</div></div><div id="widget_sp_image-2" class="widget widget_sp_image"><div class="widget-wrap"><a href="https://cnslocallife.com/category/ask-auntie/" id="" target="_self" class="widget_sp_image-image-link" title="CNS Local Life" rel=""><img width="170" height="75" alt="CNS Local Life" class="attachment-full" style="max-width: 100%;" sizes="(max-width: 170px) 100vw, 170px" src="https://caymannewsservice.com/wp-content/uploads/2016/03/Ask-Auntie-for-feed-on-CNS-170-x-75.png"/></a></div></div><div id="rss-8" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class="rsswidget" href="https://cnslocallife.com/category/ask-auntie/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://caymannewsservice.com/wp-includes/images/rss.png" alt="RSS"/></a> <a class="rsswidget" href="https://cnslocallife.com/">See Auntie&#8217;s Answers</a></span></h3><ul><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/damaged-cemetery-wall-disgrace/'>Damaged cemetery wall a disgrace</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/wants-arm-caymans-security-personnel/'>Wants to arm Cayman’s security personnel</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/may-anyone-use-toilet-designated-accessible/'>May anyone use a toilet designated accessible?</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/caymanians-voice-british-elections/'>Do Caymanians have a voice in British elections?</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/potential-buyer-thinks-strata-fees-high/'>Potential buyer thinks strata fees are too high</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/stamp-duty-assessed-inherited-property/'>How is stamp duty assessed on inherited property?</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/iguanas-fouling-track-field/'>Iguanas fouling track and field</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/election-billboard-put-without-consent/'>Election billboard put up without consent</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/upset-driver-illegally-using-disabled-spot/'>Upset by driver illegally using disabled spot</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/eligibility-caymanian-immigration-queue/'>Eligibility for the ‘Caymanian’ immigration queue</a></li></ul></div></div> </div>
<div id="sidebar-bottom-right">
<div id="rss-7" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class="rsswidget" href="https://cnsbusiness.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://caymannewsservice.com/wp-includes/images/rss.png" alt="RSS"/></a> <a class="rsswidget" href="https://cnsbusiness.com/">CNS Business</a></span></h3><ul><li><a class='rsswidget' href='https://cnsbusiness.com/2017/04/golden-spoons-review-blue-cilantro-2/'>Golden Spoons Review: Blue Cilantro</a></li><li><a class='rsswidget' href='https://cnsbusiness.com/2017/04/cima-begins-to-create-online-payment-system/'>CIMA begins to create online payment system</a></li><li><a class='rsswidget' href='https://cnsbusiness.com/2017/04/more-gas-stations-cleared-to-sell-booze/'>More gas stations cleared to sell booze</a></li><li><a class='rsswidget' href='https://cnsbusiness.com/2017/04/health-insurance-firm-u-turns-on-shetty-hospital/'>Health insurance firm U-turns on Shetty hospital</a></li></ul></div></div><div id="rss-4" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class="rsswidget" href="https://cnslocallife.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://caymannewsservice.com/wp-includes/images/rss.png" alt="RSS"/></a> <a class="rsswidget" href="https://cnslocallife.com/">CNS Local Life</a></span></h3><ul><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/ciaa-employee-navigates-new-career-path/'>CIAA employee navigates new career path</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/aall-foundation-donates-manna-centre/'>Aall Foundation donates to Manna Centre</a></li><li><a class='rsswidget' href='https://cnslocallife.com/2017/04/miss-nadines-garden-blossoming-one-year/'>Miss Nadine’s garden blossoming one year on</a></li></ul></div></div><div id="rss-6" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class="rsswidget" href="https://freecayads.com/?feed=rss2&#038;post_type=post"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://caymannewsservice.com/wp-includes/images/rss.png" alt="RSS"/></a> <a class="rsswidget" href="https://freecayads.com/">Notice Board</a></span></h3><ul><li><a class='rsswidget' href='https://freecayads.com/2017/01/25/culture-heritage-policy-public-consultation-phase-extended/'>Culture &amp; Heritage Policy Public Consultation Phase Extended</a></li><li><a class='rsswidget' href='https://freecayads.com/2017/01/24/road-blockages-this-morning-in-central-gt/'>Road Blockages This Morning in Central GT</a></li><li><a class='rsswidget' href='https://freecayads.com/2017/01/19/prospect-bypass-roundabout-closed-overnight-20th-january-2017/'>Prospect Bypass &amp; Roundabout Closed Overnight – 20th January, 2017</a></li><li><a class='rsswidget' href='https://freecayads.com/2017/01/16/the-cayman-islands-seafarers-association-general-meeting-17-jan-2017/'>The Cayman Islands Seafarers Association General Meeting 17 Jan 2017</a></li><li><a class='rsswidget' href='https://freecayads.com/2016/12/20/post-offices-december-hours/'>Post Offices’ December Hours</a></li></ul></div></div><div id="rss-5" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class="rsswidget" href="https://freecayads.com/?feed=rss2&#038;post_type=ad_listing"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://caymannewsservice.com/wp-includes/images/rss.png" alt="RSS"/></a> <a class="rsswidget" href="https://freecayads.com/">Classified Ads</a></span></h3><ul><li><a class='rsswidget' href='https://freecayads.com/ads/12-acre-lots-east-end/'>1/2 Acre Lots East End</a></li><li><a class='rsswidget' href='https://freecayads.com/ads/amazing-little-cayman-lots/'>Amazing Little Cayman Lots</a></li><li><a class='rsswidget' href='https://freecayads.com/ads/lowest-priced-brac-lots/'>Lowest Priced Brac Lots</a></li><li><a class='rsswidget' href='https://freecayads.com/ads/larger-lot-in-breakers/'>Larger Lot In Breakers</a></li><li><a class='rsswidget' href='https://freecayads.com/ads/lowest-priced-savannah-land/'>Lowest Priced Savannah Land</a></li></ul></div></div> </div>
</div>
</div>
</div>  
</div>  
</div>  
<div id="footer-widgets" class="maincontent">
<div class="limit clearfix">
<div class="footer-widget1">
<div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-wrap"><h3 class="widgettitle"><span>Recent Comments</span></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109775">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Al Catraz</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109774">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Al Catraz</span> on <a href="https://caymannewsservice.com/2017/04/cayman-environment-worth-near-200m/comment-page-1/#comment-109773">Cayman environment worth near $200M</a></li><li class="recentcomments"><span class="comment-author-link">Sue Stevens Wanninger</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109772">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/cayman-environment-worth-near-200m/comment-page-1/#comment-109771">Cayman environment worth near $200M</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/cultural-policy-to-protect-local-artists/comment-page-1/#comment-109770">Cultural policy to protect local artists</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/shooting-closes-road-near-eastern-avenue/comment-page-1/#comment-109769">Couple shot outside GT bar</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/shooting-closes-road-near-eastern-avenue/comment-page-1/#comment-109768">Couple shot outside GT bar</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109767">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109766">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Mokes-for-all</span> on <a href="https://caymannewsservice.com/2017/04/cultural-policy-to-protect-local-artists/comment-page-1/#comment-109765">Cultural policy to protect local artists</a></li><li class="recentcomments"><span class="comment-author-link">Mokes-for-all</span> on <a href="https://caymannewsservice.com/2017/04/cultural-policy-to-protect-local-artists/comment-page-1/#comment-109764">Cultural policy to protect local artists</a></li><li class="recentcomments"><span class="comment-author-link">Sharkey</span> on <a href="https://caymannewsservice.com/2017/04/shooting-closes-road-near-eastern-avenue/comment-page-1/#comment-109763">Couple shot outside GT bar</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/animal-activists-target-carnivals-turtle-farm-trips/comment-page-1/#comment-109762">Animal activists target Carnival&#8217;s turtle farm trips</a></li><li class="recentcomments"><span class="comment-author-link">Anonymous</span> on <a href="https://caymannewsservice.com/2017/04/travel-agent-cleared-of-14-fraud-charges/comment-page-1/#comment-109761">Travel agent cleared of 14 fraud charges</a></li></ul></div></div> </div>
<div class="footer-widget2">
<div id="calendar-2" class="widget widget_calendar"><div class="widget-wrap"><h3 class="widgettitle"><span>CNS Archives by date</span></h3><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>April 2017</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="https://caymannewsservice.com/2017/03/">&laquo; Mar</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="5" class="pad">&nbsp;</td><td>1</td><td>2</td>
</tr>
<tr>
<td><a href="https://caymannewsservice.com/2017/04/03/" aria-label="Posts published on April 3, 2017">3</a></td><td><a href="https://caymannewsservice.com/2017/04/04/" aria-label="Posts published on April 4, 2017">4</a></td><td><a href="https://caymannewsservice.com/2017/04/05/" aria-label="Posts published on April 5, 2017">5</a></td><td><a href="https://caymannewsservice.com/2017/04/06/" aria-label="Posts published on April 6, 2017">6</a></td><td><a href="https://caymannewsservice.com/2017/04/07/" aria-label="Posts published on April 7, 2017">7</a></td><td><a href="https://caymannewsservice.com/2017/04/08/" aria-label="Posts published on April 8, 2017">8</a></td><td>9</td>
</tr>
<tr>
<td><a href="https://caymannewsservice.com/2017/04/10/" aria-label="Posts published on April 10, 2017">10</a></td><td><a href="https://caymannewsservice.com/2017/04/11/" aria-label="Posts published on April 11, 2017">11</a></td><td><a href="https://caymannewsservice.com/2017/04/12/" aria-label="Posts published on April 12, 2017">12</a></td><td><a href="https://caymannewsservice.com/2017/04/13/" aria-label="Posts published on April 13, 2017">13</a></td><td>14</td><td><a href="https://caymannewsservice.com/2017/04/15/" aria-label="Posts published on April 15, 2017">15</a></td><td>16</td>
</tr>
<tr>
<td><a href="https://caymannewsservice.com/2017/04/17/" aria-label="Posts published on April 17, 2017">17</a></td><td><a href="https://caymannewsservice.com/2017/04/18/" aria-label="Posts published on April 18, 2017">18</a></td><td><a href="https://caymannewsservice.com/2017/04/19/" aria-label="Posts published on April 19, 2017">19</a></td><td><a href="https://caymannewsservice.com/2017/04/20/" aria-label="Posts published on April 20, 2017">20</a></td><td><a href="https://caymannewsservice.com/2017/04/21/" aria-label="Posts published on April 21, 2017">21</a></td><td>22</td><td><a href="https://caymannewsservice.com/2017/04/23/" aria-label="Posts published on April 23, 2017">23</a></td>
</tr>
<tr>
<td><a href="https://caymannewsservice.com/2017/04/24/" aria-label="Posts published on April 24, 2017">24</a></td><td><a href="https://caymannewsservice.com/2017/04/25/" aria-label="Posts published on April 25, 2017">25</a></td><td><a href="https://caymannewsservice.com/2017/04/26/" aria-label="Posts published on April 26, 2017">26</a></td><td id="today"><a href="https://caymannewsservice.com/2017/04/27/" aria-label="Posts published on April 27, 2017">27</a></td><td>28</td><td>29</td><td>30</td>
</tr>
</tbody>
</table></div></div></div> </div>
<div class="footer-widget3">
</div>
<div class="footer-widget4">
<div id="tag_cloud-2" class="widget widget_tag_cloud"><div class="widget-wrap"><h3 class="widgettitle"><span>Tags</span></h3><div class="tagcloud"><a href='https://caymannewsservice.com/tag/alden-mclaughlin/' class='tag-link-43 tag-link-position-1' title='246 topics' style='font-size: 15.287671232877pt;'>Alden McLaughlin</a>
<a href='https://caymannewsservice.com/tag/armed-robbery/' class='tag-link-155 tag-link-position-2' title='125 topics' style='font-size: 12.506849315068pt;'>armed robbery</a>
<a href='https://caymannewsservice.com/tag/burglary/' class='tag-link-505 tag-link-position-3' title='69 topics' style='font-size: 10.109589041096pt;'>burglary</a>
<a href='https://caymannewsservice.com/tag/canover-watson/' class='tag-link-315 tag-link-position-4' title='53 topics' style='font-size: 8.958904109589pt;'>Canover Watson</a>
<a href='https://caymannewsservice.com/tag/cayman-brac/' class='tag-link-113 tag-link-position-5' title='42 topics' style='font-size: 8pt;'>Cayman Brac</a>
<a href='https://caymannewsservice.com/tag/cayman-islands-football-association/' class='tag-link-242 tag-link-position-6' title='52 topics' style='font-size: 8.8630136986301pt;'>Cayman Islands Football Association</a>
<a href='https://caymannewsservice.com/tag/cns-business/' class='tag-link-228 tag-link-position-7' title='142 topics' style='font-size: 13.082191780822pt;'>CNS Business</a>
<a href='https://caymannewsservice.com/tag/cns-local-life/' class='tag-link-327 tag-link-position-8' title='59 topics' style='font-size: 9.4383561643836pt;'>CNS Local Life</a>
<a href='https://caymannewsservice.com/tag/concacaf/' class='tag-link-140 tag-link-position-9' title='52 topics' style='font-size: 8.8630136986301pt;'>CONCACAF</a>
<a href='https://caymannewsservice.com/tag/corruption/' class='tag-link-162 tag-link-position-10' title='94 topics' style='font-size: 11.356164383562pt;'>corruption</a>
<a href='https://caymannewsservice.com/tag/cruise-dock-facility/' class='tag-link-477 tag-link-position-11' title='74 topics' style='font-size: 10.397260273973pt;'>cruise dock facility</a>
<a href='https://caymannewsservice.com/tag/cuban-migrants/' class='tag-link-54 tag-link-position-12' title='52 topics' style='font-size: 8.8630136986301pt;'>Cuban migrants</a>
<a href='https://caymannewsservice.com/tag/david-baines/' class='tag-link-38 tag-link-position-13' title='57 topics' style='font-size: 9.2465753424658pt;'>David Baines</a>
<a href='https://caymannewsservice.com/tag/department-of-environment/' class='tag-link-353 tag-link-position-14' title='69 topics' style='font-size: 10.109589041096pt;'>Department of Environment</a>
<a href='https://caymannewsservice.com/tag/drug-crime/' class='tag-link-225 tag-link-position-15' title='92 topics' style='font-size: 11.260273972603pt;'>drug crime</a>
<a href='https://caymannewsservice.com/tag/ezzard-miller/' class='tag-link-88 tag-link-position-16' title='79 topics' style='font-size: 10.58904109589pt;'>Ezzard Miller</a>
<a href='https://caymannewsservice.com/tag/fatality/' class='tag-link-56 tag-link-position-17' title='117 topics' style='font-size: 12.219178082192pt;'>fatality</a>
<a href='https://caymannewsservice.com/tag/featured/' class='tag-link-5 tag-link-position-18' title='1,233 topics' style='font-size: 22pt;'>Featured</a>
<a href='https://caymannewsservice.com/tag/fifa/' class='tag-link-282 tag-link-position-19' title='62 topics' style='font-size: 9.6301369863014pt;'>FIFA</a>
<a href='https://caymannewsservice.com/tag/franz-manderson/' class='tag-link-145 tag-link-position-20' title='44 topics' style='font-size: 8.1917808219178pt;'>Franz Manderson</a>
<a href='https://caymannewsservice.com/tag/fraud/' class='tag-link-126 tag-link-position-21' title='42 topics' style='font-size: 8pt;'>fraud</a>
<a href='https://caymannewsservice.com/tag/gangs/' class='tag-link-71 tag-link-position-22' title='49 topics' style='font-size: 8.6712328767123pt;'>gangs</a>
<a href='https://caymannewsservice.com/tag/gay-rights/' class='tag-link-80 tag-link-position-23' title='43 topics' style='font-size: 8.0958904109589pt;'>gay rights</a>
<a href='https://caymannewsservice.com/tag/gun-crime/' class='tag-link-52 tag-link-position-24' title='188 topics' style='font-size: 14.232876712329pt;'>gun crime</a>
<a href='https://caymannewsservice.com/tag/hmp-northward/' class='tag-link-260 tag-link-position-25' title='49 topics' style='font-size: 8.6712328767123pt;'>HMP Northward</a>
<a href='https://caymannewsservice.com/tag/hsa/' class='tag-link-62 tag-link-position-26' title='69 topics' style='font-size: 10.109589041096pt;'>HSA</a>
<a href='https://caymannewsservice.com/tag/jeff-webb/' class='tag-link-139 tag-link-position-27' title='97 topics' style='font-size: 11.452054794521pt;'>Jeff Webb</a>
<a href='https://caymannewsservice.com/tag/lgbt-community/' class='tag-link-610 tag-link-position-28' title='44 topics' style='font-size: 8.1917808219178pt;'>LGBT community</a>
<a href='https://caymannewsservice.com/tag/marco-archer/' class='tag-link-29 tag-link-position-29' title='59 topics' style='font-size: 9.4383561643836pt;'>Marco Archer</a>
<a href='https://caymannewsservice.com/tag/mckeeva-bush/' class='tag-link-40 tag-link-position-30' title='85 topics' style='font-size: 10.876712328767pt;'>McKeeva Bush</a>
<a href='https://caymannewsservice.com/tag/murder/' class='tag-link-57 tag-link-position-31' title='43 topics' style='font-size: 8.0958904109589pt;'>murder</a>
<a href='https://caymannewsservice.com/tag/murder-trial/' class='tag-link-41 tag-link-position-32' title='59 topics' style='font-size: 9.4383561643836pt;'>murder trial</a>
<a href='https://caymannewsservice.com/tag/office-of-the-auditor-general/' class='tag-link-30 tag-link-position-33' title='75 topics' style='font-size: 10.397260273973pt;'>Office of the Auditor General</a>
<a href='https://caymannewsservice.com/tag/osbourne-bodden/' class='tag-link-33 tag-link-position-34' title='42 topics' style='font-size: 8pt;'>Osbourne Bodden</a>
<a href='https://caymannewsservice.com/tag/public-accounts-committee/' class='tag-link-144 tag-link-position-35' title='49 topics' style='font-size: 8.6712328767123pt;'>Public Accounts Committee</a>
<a href='https://caymannewsservice.com/tag/rcips/' class='tag-link-39 tag-link-position-36' title='99 topics' style='font-size: 11.547945205479pt;'>RCIPS</a>
<a href='https://caymannewsservice.com/tag/rcips-joint-marine-unit/' class='tag-link-60 tag-link-position-37' title='44 topics' style='font-size: 8.1917808219178pt;'>RCIPS Joint Marine Unit</a>
<a href='https://caymannewsservice.com/tag/road-accident/' class='tag-link-55 tag-link-position-38' title='148 topics' style='font-size: 13.178082191781pt;'>road accident</a>
<a href='https://caymannewsservice.com/tag/sex-crimes/' class='tag-link-185 tag-link-position-39' title='106 topics' style='font-size: 11.835616438356pt;'>sex crimes</a>
<a href='https://caymannewsservice.com/tag/stabbing/' class='tag-link-313 tag-link-position-40' title='59 topics' style='font-size: 9.4383561643836pt;'>stabbing</a>
<a href='https://caymannewsservice.com/tag/tara-rivers/' class='tag-link-97 tag-link-position-41' title='76 topics' style='font-size: 10.493150684932pt;'>Tara Rivers</a>
<a href='https://caymannewsservice.com/tag/theft/' class='tag-link-121 tag-link-position-42' title='148 topics' style='font-size: 13.178082191781pt;'>theft</a>
<a href='https://caymannewsservice.com/tag/violent-crime/' class='tag-link-129 tag-link-position-43' title='86 topics' style='font-size: 10.972602739726pt;'>violent crime</a>
<a href='https://caymannewsservice.com/tag/water-accident/' class='tag-link-124 tag-link-position-44' title='53 topics' style='font-size: 8.958904109589pt;'>water accident</a>
<a href='https://caymannewsservice.com/tag/wayne-panton/' class='tag-link-264 tag-link-position-45' title='52 topics' style='font-size: 8.8630136986301pt;'>Wayne Panton</a></div>
</div></div> </div>
</div>
</div>  
<div id="footer">
<div class="limit clearfix">
<p class="footurl"><a href="https://caymannewsservice.com">Cayman News Service</a></p>
&copy; 2017 Cayman News Service. All rights reserved. <a href="http://www.solostream.com" rel="nofollow">Theme by Solostream</a>.
</div>
</div>  
</div>  
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/caymannewsservice.com\/2017\/04\/how-would-you-grade-your-mlas-this-past-term-part-2\/":18326};
	</script>
<div id="sharing_email" style="display: none;">
<form action="/2017/04/how-would-you-grade-your-mlas-this-past-term-part-2/" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value=""/>
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value=""/>
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value=""/>
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed"/>
<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
<img style="float: right; display: none" class="loading" src="https://caymannewsservice.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16"/>
<input type="submit" value="Send Email" class="sharing_send"/>
<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201717'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-includes/js/wp-embed.min.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-includes/js/comment-reply.min.js?ver=b0f9b0af916f663cfbd0bf1d238105a7'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://caymannewsservice.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.8.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
</script>
<iframe src='https://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429&amp;lang=en-gb' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script type='text/javascript' src='https://stats.wp.com/e-201717.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'77091667',post:'18326',tz:'-5',srv:'caymannewsservice.com'} ]);
	_stq.push([ 'clickTrackerInit', '77091667', '18326' ]);
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2900728-1', 'auto');
  ga('send', 'pageview');

</script>
</body>
</html>
 